violet-pink strips screen shown in search result of firefox for android v41.0

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: TanhaIslam, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(fennec42+)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8666600 [details]
Screenshot_2015-09-28-13-37-31.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

I wanted to search normally in the search bar of firefox for android. 


Actual results:

I got my actual results but the screen was violet pink strips. This happened to me since I downloaded a fresh version of firefox for my android. This only happens the first time I search for anything. Rest of the time, the browser acts normally.


Expected results:

It should have shown me a normal results of the topic I searched on a white page.

Comment 1

3 years ago
Following the reproduction steps stated in the description and using the latest Nightly build (44.0a1), the issues could not be reproduced on:
 Xiaomi Mi i4 with 5.0.2 Android and 
 Alcatel One Touch (Android 4.1.2)

 TanhaIslam, 
Could you please verify if the issue still can be reproduced on your device by using the latest Nightly buid?
Flags: needinfo?(pink.devil.tanha)
(Reporter)

Comment 2

3 years ago
hello,
I just tried to reproduce the step again on my latest nightly build and it works fine!
Flags: needinfo?(pink.devil.tanha)

Comment 3

3 years ago
Failed to reproduce the bug on Fennec , Version: 41.0 , Build ID: 20150917151118 , I am using UMI IRON (android 5.1) .
Which device (model number) and what version of Android are you using.
Flags: needinfo?(pink.devil.tanha)
(Reporter)

Comment 5

3 years ago
Device: Walton primo GH2.
Version: 4.4.2
Flags: needinfo?(pink.devil.tanha)
According to the internet this is the same phone http://www.gsmarena.com/gionee_pioneer_p4-6711.php we would likely need to obtain this device to resolve this issue.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
(Reporter)

Comment 7

3 years ago
I guess this one. Another person who faced this, I have CC'ed him too.

Comment 8

3 years ago
Created attachment 8667121 [details]
Screenshot_2015-09-29-13-06-30.png

Thanks for the cc;
I faced the problem on my Xiaomi Mi 4 (http://www.gsmarena.com/xiaomi_mi_4-6518.php). I have added a screenshot with my comment; 
This problem occurs when I try to search something just after opening the browser. 

Name: Fennec ; 
Version: 41.0 ;
Build ID: 20150917151118 ;
Update Channel: release ;
tracking-fennec: ? → 42+
Tried to reproduce this on the devices I have on hand. Was not able to. Going to servicenow a Xiaomi Mi 4.

Comment 11

3 years ago
This is our most common compat/rendering feedback in 41 so far.  It does not seem to be isolated to a single family of devices.  I have not found this issue in pre-41 (or post-41 for that matter).

https://input.mozilla.org/en-US/?q=violet+purple+pink&product=Firefox+for+Android&date_end=2015-10-20&date_start=2015-09-22

Comment 12

3 years ago
snorp, can we get an assignee here?
Flags: needinfo?(snorp)
Duplicate of this bug: 1212234
I received a Xiaomi Mi 4. Model number MI 4LTE-CU currently running Android 4.4.4 KTU84P and MIUI version 6.4.2.0(KXDCNCB)|Stable. I don't see the pink/purple lines using either Firefox for Android from the MI Store (which looks to be the Mozilla CN version) or the version we ship to the Play store. I have an update to MIUI 7.0.5.0 available but don't want to take it until we know more about the device settings.

I also tested using several of the GPU options in the Android developer settings to see if they caused the issue. So far they don't seem to have any effect.

Towaha would you provide the device details from your Mi4 in the 'About Phone' settings?
Flags: needinfo?(soft)

Comment 15

3 years ago
Model No. : mi 4i
Android Version: 5.0.2LRX22G
MIUI version: 5.7.3 | Beta
CPU: Octa-core, Max 1.7GHz
RAM: 2.00GB

I guess i need to update the MiUi version; I'll take care of it tomorrow. 

@Kevin, Do you need the kernel and baseband version?
Flags: needinfo?(soft)
No. I wonder if this only manifests on Android 5. I will try upgrading my device.
I don't think I have the right device it seems that the Mi 4i LTE is different than the model you are using. It will only update to Android 4.4. The Softvision team also has a Mi 4i that is running Android 5 lets see if their device can reproduce. This might require Firefox 41.
Flags: needinfo?(ioana.chiorean)
If we can find a device, etc, I can get someone to look at it.
Flags: needinfo?(snorp)

Comment 19

3 years ago
This issue could be reproduced on the release build 41.0 on both:
 - Prestigio Grace x5 - Android 4.4.2 - GPU Mali chipset (same as device from comm 5)
 - Prestigio MultiPhone 5508 DUO - Android 4.4.2 - GPU Mali chipset (same as device from comm 5)

On both previous mentioned devices, the issue could NOT be reproduced on latest release build (42.0.1)
Flags: needinfo?(ioana.chiorean)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.