Closed Bug 1209265 Opened 7 years ago Closed 6 years ago

small or zero @page { margin: ...} values should suppress added headers and footers

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1250674
Tracking Status
firefox44 --- affected

People

(Reporter: dbaron, Unassigned)

Details

(Keywords: css2)

bug 115199 implemented support for the @page rule and the margin property inside it.

I've heard that Chrome, given @page { margin:0 }, suppresses the printing of headers and footers so that the site can control the whole space of the page.

While bug 856371 covers implementing the page margin boxes proposal in css3-page, which gives much more control over headers and footers, we may well want to look at making our behavior for small (how small?) margin values of @page match Chrome's.

Sites want this behavior in order to print document-like things with their own (or no) headers and footers.

It's worth testing other browser behavior first here, though.
Keywords: css2
It's also probably worth researching whether any specs say that this should happen or that this shouldn't happen.  (If they say it shouldn't, it's probably worth pushing them towards matching reality, unless there's a good reason for what they say.)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1250674
You need to log in before you can comment on or make changes to this bug.