"This message may be a scam" notification is really hard to read with GTK3 and Ubuntu

RESOLVED FIXED in Firefox 43

Status

()

Toolkit
Themes
RESOLVED FIXED
2 years ago
7 months ago

People

(Reporter: dholbert, Assigned: Paenglab)

Tracking

({regression})

unspecified
mozilla44
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 unaffected, firefox42 unaffected, firefox43 fixed, firefox44 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
STR:
 1. View a message that Thunderbird thinks is a scam, in Thunderbird Aurora (v43)

ACTUAL RESULTS: The scam warning is unreadable (white on light yellow). See attached screenshot.

EXPECTED RESULTS: Readable text.


NOTE: The "blocked remote content" notification uses a different text-color and is consistent with what I'd expect from using OS-dependent theming, based on bug 1198063.

I'm using Ubuntu 15.10 prerelease (currently beta, releasing this month) and Earlybird 43.0a2 (2015-09-28) (thunderbird aurora channel)
(Reporter)

Comment 1

2 years ago
Created attachment 8667009 [details]
screenshot of bug (scam warning), white-on-yellow, unreadable
(Reporter)

Comment 2

2 years ago
Created attachment 8667012 [details]
screenshot of content-blocked notification -- gray-on-yellow, expected per bug 1206516

For comparison, here's the more-readable other notification, which is rendering as expected per bug 1206516.
(Reporter)

Comment 3

2 years ago
I'm guessing we use a special text-color on the scam notification, with the intention of being extra-visible -- but in this case it means we're extra-invisible. :-/
(Reporter)

Comment 4

2 years ago
(In reply to Daniel Holbert [:dholbert] from comment #0)
> I'm using Ubuntu 15.10 prerelease (currently beta, releasing this month) and
> Earlybird 43.0a2 (2015-09-28) (thunderbird aurora channel)

I can reproduce this on a different machine running Ubuntu 15.04 as well.

(Also: I noticed that I need to tick a checkbox before the scam notifications will show up -- there's a checkbox in the Thunderbird Preferences "Security" pane.)
(Reporter)

Comment 5

2 years ago
Requesting tracking, since this is a regression which effectively disables a security feature by rendering its warning unreadable.
Blocks: 627699
tracking-thunderbird43: --- → ?
Keywords: regression
See Also: → bug 1198063
(Reporter)

Updated

2 years ago
See Also: → bug 1187203
(Assignee)

Comment 6

2 years ago
This is a toolkit issue. The color is set here: https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/notification.css?offset=200#20 . With the corresponding background-image it would be white on red. But with the -moz-appearance: -moz-gtk-info-bar; set here: https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/notification.css?offset=200#10 the background-image isn't used. With setting -moz-appearance: none; like on https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/notification.css?offset=200#17 the red would be shown.

If you want to go this way I can make a patch.
tracking-thunderbird43: ? → ---
Component: Theme → Themes
Product: Thunderbird → Toolkit
(Reporter)

Comment 7

2 years ago
(In reply to Richard Marti (:Paenglab) from comment #6)
> This is a toolkit issue. The color is set here:
> https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/
> notification.css?offset=200#20

Thanks for the diagnosis! CC'ing adw, who last touched that line (to fix a similar black-text-on-dark-background bug, bug 1130850).

"-moz-appearance:none" does sound like it would work, but it would remove the native look-and-feel which seems unfortunate.  Hopefully adw can make a call (or defer to someone who can) about what's the right solution here.
Flags: needinfo?(adw)
(Reporter)

Comment 8

2 years ago
oh, I spoke too soon -- I think I agree that "-moz-appearance: none" is actually the right solution after all. It sounds like this dropdown's background *used* to be drawn (native-looking or not) via the "background" or "background-image" properties, and we were *intentionally* overriding the native background-color in this notification[type="critical"] rule.  But now that the native background is drawn via "-moz-appearance" (as a result of bug 1198063's fix), the formerly-overriding "background-image" in this [critical] declaration doesn't end up being visible.

So: if I'm understanding correctly, I think I agree with Paenglab that we should add "-moz-appearance:none" to this notification[type="critical"] rule.  Hopefully adw can confirm and/or review the patch.
(Assignee)

Comment 9

2 years ago
Created attachment 8667495 [details] [diff] [review]
Bug1209343.patch

Add the -moz-appearance: none;
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8667495 - Flags: review?(adw)

Comment 10

2 years ago
Comment on attachment 8667495 [details] [diff] [review]
Bug1209343.patch

Review of attachment 8667495 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, makes sense and works as advertised.
Attachment #8667495 - Flags: review?(adw) → review+

Updated

2 years ago
Flags: needinfo?(adw)
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 11

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/ed34103d8978
Keywords: checkin-needed
(Reporter)

Comment 12

2 years ago
(Tree sheriffs generally require a Try build before they'll land checkin-needed patches. But I'm pretty sure this doesn't need a Try build, so I just went ahead and pushed, to bypass that back-and-forth with sheriffs.)

This needs backporting to Aurora 43 [which is where I encountered it, in Thunderbird].  Richard, could you request aurora approval?
status-firefox43: --- → affected
status-firefox44: --- → fixed
Flags: needinfo?(richard.marti)
(Assignee)

Comment 13

2 years ago
Comment on attachment 8667495 [details] [diff] [review]
Bug1209343.patch

Approval Request Comment
[Feature/regressing bug #]: 1187203
[User impact if declined]: Unreadable critical notification bars
[Describe test coverage new/current, TreeHerder]: On the way to m-c
[Risks and why]: No risk, only CSS one liner
[String/UUID change made/needed]: none
Flags: needinfo?(richard.marti)
Attachment #8667495 - Flags: approval-mozilla-aurora?
(Reporter)

Comment 14

2 years ago
Note:
 - version 42 [current beta] is unaffected, because we disabled GTK3 on that branch (bug 1207310).
 - version 41 [current release] is unaffected, because GTK3 wasn't turned on until trunk hit version 42 (bug 1186003).  Plus, the regressing patch -- bug 1187203 -- didn't land until in Firefox 42.
status-firefox41: --- → unaffected
status-firefox42: --- → unaffected
https://hg.mozilla.org/mozilla-central/rev/ed34103d8978
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Comment on attachment 8667495 [details] [diff] [review]
Bug1209343.patch

OK to uplift to aurora, minor CSS fix.
Attachment #8667495 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/987bcf61861a
status-firefox43: affected → fixed

Updated

a year ago
Duplicate of this bug: 1199953

Updated

7 months ago
Depends on: 1187203
See Also: bug 1187203
You need to log in before you can comment on or make changes to this bug.