Closed Bug 1209598 Opened 5 years ago Closed 5 years ago

suspend() fails when AudioContext.state is "suspended"

Categories

(Core :: Web Audio, defect, P2)

40 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1269741

People

(Reporter: karlt, Assigned: padenot)

References

Details

It should be possible to suspend() a new AudioContext or an AudioContext on which resume() has recently been called, but state has not yet changed.
Blocks: 1198386
Noticed in bug 1164814 comment 1 and bug 1198386 comment 572.
See Also: → 1164814
It's sad that the spec is completely silent about what actually needs to happen in suspend().  <http://webaudio.github.io/web-audio-api/#widl-AudioContext-suspend-Promise-void>  We should fix the spec as well.
Flags: needinfo?(padenot)
(In reply to Ehsan Akhgari (don't ask for review please) from comment #2)
> It's sad that the spec is completely silent about what actually needs to
> happen in suspend(). 
> <http://webaudio.github.io/web-audio-api/#widl-AudioContext-suspend-Promise-
> void>  We should fix the spec as well.

I'm currently speccing the processing model of the Web Audio API (to have a solid ground on which we can build what was called the AudioWorker), and in particular asynchronous and synchronous parts [0] of method calls, this will allow us to spec this properly.

I was going to go all over the spec and mark synchronous and asynchronous parts of all the operations today, so I can do that as I fix everything else, as well. This is due to merge hopefully before TPAC or shortly after.

[0]: http://padenot.github.io/web-audio-api/#asynchronous-operations
Flags: needinfo?(padenot)
Assignee: nobody → padenot
(In reply to Paul Adenot (:padenot) from comment #3)
> (In reply to Ehsan Akhgari (don't ask for review please) from comment #2)
> > It's sad that the spec is completely silent about what actually needs to
> > happen in suspend(). 
> > <http://webaudio.github.io/web-audio-api/#widl-AudioContext-suspend-Promise-
> > void>  We should fix the spec as well.
> 
> I'm currently speccing the processing model of the Web Audio API (to have a
> solid ground on which we can build what was called the AudioWorker), and in
> particular asynchronous and synchronous parts [0] of method calls, this will
> allow us to spec this properly.
> 
> I was going to go all over the spec and mark synchronous and asynchronous
> parts of all the operations today, so I can do that as I fix everything
> else, as well. This is due to merge hopefully before TPAC or shortly after.
> 
> [0]: http://padenot.github.io/web-audio-api/#asynchronous-operations

This is now done, still on my branch, and up for review to the group. For example, close:

http://padenot.github.io/web-audio-api/#widl-AudioContext-close-Promise-void

I'll now fix gecko.
Thanks, Paul!
Rank: 25
Priority: -- → P2
Depends on: 1269741
Status: NEW → RESOLVED
Closed: 5 years ago
No longer depends on: 1269741
Resolution: --- → DUPLICATE
Duplicate of bug: 1269741
You need to log in before you can comment on or make changes to this bug.