Closed Bug 1209900 Opened 4 years ago Closed 4 years ago

[SMS]After a wbesite image is pasted into message, the "Message" hint text is displayed over the pasted image.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 disabled, b2g-master affected)

RESOLVED DUPLICATE of bug 1207083
Tracking Status
b2g-v2.2 --- disabled
b2g-master --- affected

People

(Reporter: huxiaoyan, Unassigned)

References

Details

(Whiteboard: [2.5-aries-test-run-2])

Attachments

(2 files)

[1.Description]:
[Flame KK v2.5][Aries KK v2.5][SMS]Copy a picture from Browser app, then paste the picture into message text field(Message app), the  "Message"  hint text is displayed over the pasted image.
Found Time: 15:05
See attachments:logcat_1505.txt and  Aries_KK_v2.5.3gp

[2.Testing Steps]: 
1. Launch Browser app.
2. Navigate to "www.baidu.com, then enter "tupian" on search bar.
3. Select a picture, and long tap it.
4. Select "Copy Image", then tap home button.
5. Open SMS app, long tap any place in message text field to paste, then observe it.

[3.Expected Result]: 
5. The pasted image is displayed in message text field, and there is no character over the pasted image.

[4.Actual Result]: 
5. The "Message" hint text is displayed on the top left of pasted image.

[5.Reproduction build]: 
Device: Aries KK v2.5(Affected)
Build ID               20150930005445
Gaia Revision          1bc0b19527777ffee494962b48db4be857b07d64
Gaia Date              2015-09-29 20:01:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/891ee0d0ba3ec42b6484cf0205b3c95e21c58f74
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150930.001258
Firmware Date          Wed Sep 30 00:13:06 UTC 2015
Bootloader             s1

Device: Flame KK v2.5(Affected)
Build ID               20150929150202
Gaia Revision          f345f6a015709beeb2ca3955cab077fcaa959d3b
Gaia Date              2015-09-29 03:53:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ccee6614fd9d18a31f263fbcfe9676b224d851aa
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150929.201052
Firmware Date          Tue Sep 29 20:11:01 EDT 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.2(Disabled)
Build ID               20150929032504
Gaia Revision          5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gaia Date              2015-09-21 11:20:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/65ddad73ad6b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150929.064906
Firmware Date          Tue Sep 29 06:49:17 EDT 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
I believe this is the same reason than bug 1207083: rich text pasting that we don't support...
Attached file logcat_1505.txt
Attached video Aries_KK_v2.5.3gp
(In reply to Julien Wajsberg [:julienw] (away Oct 1st, 2nd) from comment #1)
> I believe this is the same reason than bug 1207083: rich text pasting that
> we don't support...

Thanks for the information. :)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: sms-rich-paste-composer
You need to log in before you can comment on or make changes to this bug.