Locale conflict with OS in "open file" dialog

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: danpiel, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150929004011

Steps to reproduce:

Just open file for upload from any website

OS: Mac OS X El Capitan 10.11 Beta (15A278b), English as system language
Firefox: 43.0a2 (2015-09-29) Russian version



Actual results:

In open file dialogue names of folders changes between Russian (browser locale) and English (system locale)

Recorded a gif for preview http://g.recordit.co/zUYTEciv61.gif


Expected results:

Should display english names of folders taken from system.

Comment 1

4 years ago
why does it sound like a Mac OS bug to me, 
did you face this with other browsers too ?? 

could not reproduce on my Kubuntu - 64 bit
added a testcase in the url field.
Still Arni can have a look at this
Thanks
QA Whiteboard: [testday-20151127]
Flags: needinfo?(arni2033)

Comment 2

4 years ago
I definitely don't see this issue on russian_win7 with both english and russian versions of FF.
Flags: needinfo?(arni2033)
Reporter

Comment 3

4 years ago
Now I can't reproduce this bug in 44.0a2 (2015-11-29), seems somewhere it was fixed, thank you for your time. Marking bug as resolved
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.