If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in @0x0 | mozilla::gl::ReadBuffer::`scalar deleting destructor''(unsigned int)

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Ovidiu, Assigned: eflores)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-9eff6b1d-01c8-410f-b896-460582150930.
=============================================================
Reproduce this crashe on Windows 7 x64 with latest aurora, build id 20150930004021


Steps to reproduce:

1 Open Firefox (aurora) developers edition.
2 Go on this link https://wiki.mozilla.org/QA/Games#Public_Demos
3 Go to http://playcanv.as/b/DM950Kkf
4 Play about 1 minute. 
5  Go back and select link http://cabbi.bo/weirdkids/ from the list.
6 Play about 1 minute.
7 Go back and select link  https://www.shadertoy.com/

Expected results: You are able to play the games without problems.
Actual results: Firefox crashes.


Reports: 

 bp-ed6234b2-a1bf-44a9-ba89-8c32e2150930
 bp-9eff6b1d-01c8-410f-b896-460582150930

Updated

2 years ago
Crash Signature: [@ @0x0 | mozilla::gl::ReadBuffer::`scalar deleting destructor''(unsigned int)] → [@ @0x0 | mozilla::gl::ReadBuffer::`scalar deleting destructor''(unsigned int)] [@ @0x0 | mozilla::gl::ReadBuffer::`scalar deleting destructor'']
Looks the same as bug 1227548.
Assignee: nobody → edwin
Hi, does this still happen on latest Nightly?
Flags: needinfo?(ovidiu.boca)
(Reporter)

Comment 3

2 years ago
Hi, 

I tested on Nightly 47.0a1 and I can't reproduce the crash, but I had a hang after I followed the first 4 steps, this it was just one time hang, I retested and I couldn't reproduce the hang. I also tested on aurora and I can't reproduce it. I will close this as Resolved: WFM and If I'll be able to reproduce it in the future I'll reopen this issue. Thank you
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(ovidiu.boca)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.