Closed Bug 1210117 Opened 4 years ago Closed 4 years ago

Intermittent e10s test_scroll_inactive_flattened_frame.html | nested scrollframe should have scrolled

Categories

(Core :: Panning and Zooming, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
e10s + ---
firefox47 --- fixed
firefox48 --- fixed

People

(Reporter: KWierso, Assigned: botond)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [gfx-noted])

Attachments

(1 file)

Component: Graphics: Layers → Panning and Zooming
Summary: Intermittent test_scroll_inactive_flattened_frame.html | nested scrollframe should have scrolled → Intermittent e10s test_scroll_inactive_flattened_frame.html | nested scrollframe should have scrolled
Blocks: e10s-tests
tracking-e10s: --- → +
Assignee: nobody → bugmail.mozilla
Blanket gfx-noted on APZ intermittent failures so they can be found more easily on https://brasstacks.mozilla.com/orangefactor/
Whiteboard: [gfx-noted]
I can't repro this locally even with chaos mode. I'll try debugging via try pushes.
Given the lack of reproduction on my try push so far [1] I suspect there might be interference from a previous test during a normal all-mochitest push.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=5a25a7cdc3aa&group_state=expanded
The intermittent failure here should be fixed by bug 1213095; the root cause is the same, just on a different test.
Depends on: 1213095
I don't see any of these in orangefactor after bug 1213095 landed.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213095
This affects OSX 10.6 e10s as well, it appears.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
See Also: → 1252875
Caught it with extra logging: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9cd7ed658735&selectedJob=17719579

Looks like test_scroll_inactive_flattened_frame.html starts, and the wheel event it sends gets added to the wheel block from a previous test. I think we just need to make the test wait for the paints to be flushed and so on before it starts running. Will take care of it tomorrow if Botond doesn't beat me to it :)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #27)
> Will take care of it tomorrow if Botond doesn't beat me to it :)

I'll take that as an invitation :)
Comment on attachment 8727683 [details]
MozReview Request: Bug 1210117 - Flush paints before running the test body in test_scroll_inactive_flattened_frame.html. r=kats

https://reviewboard.mozilla.org/r/38605/#review35249

Thanks! :)
Attachment #8727683 - Flags: review?(bugmail.mozilla) → review+
I triggered autoland on this patch.
Assignee: bugmail.mozilla → botond
https://hg.mozilla.org/mozilla-central/rev/48c1800e5b2c
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.