Screensaver starts, then display turns off while playing html5 video (fx 41)

RESOLVED DUPLICATE of bug 1193610

Status

()

Core
Audio/Video: Playback
P1
normal
RESOLVED DUPLICATE of bug 1193610
2 years ago
2 years ago

People

(Reporter: julia breink, Unassigned, NeedInfo)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150917150946

Steps to reproduce:

Play any html5 video (doesn't matter if it's fullscreen or not), do not move mouse.


Actual results:

First, if it's enabled, screensaver will start, after a specified time.
Then, display will turn off.


Expected results:

Nothing should've happened, screen shouldn't turn off while video is playing.

Comment 1

2 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
20150917150946

I can't reproduce this. I set the screensaver to the minimum of 1 minute, then tried a YouTube video and this random search result:
http://www.html5videoplayer.net/html5video/mp4-h-264-video-test/

Please test in a brand new profile.
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit
Summary: display is turning off while playing html5 video (fx 41) → Screensaver starts, then display turns off while playing html5 video (fx 41)
(Reporter)

Comment 2

2 years ago
(In reply to Gingerbread Man from comment #1)

> Please test in a brand new profile.

New profile didn't help, screensaver still starting, while video is playing.

Comment 3

2 years ago
Anthony, do you know whether we try to suppress the screen saver while videos are playing currently?
Flags: needinfo?(ajones)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> Anthony, do you know whether we try to suppress the screen saver while
> videos are playing currently?

We should suppress the screensaver when playing full screen video. There are too many screen savers on Linux for it work on all of them. However this issue may have been fixed in another bug relating to XP screensavers.
Component: Video/Audio Controls → Audio/Video: Playback
Flags: needinfo?(ajones)
Product: Toolkit → Core
Priority: -- → P1

Comment 5

2 years ago
Reporter, please test the latest Nightly in a brand new profile and report back whether the screen saver still kicks in.
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
https://nightly.mozilla.org

(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #4)
> this issue may have been fixed in another bug relating to XP screensavers.

Bug 1193610.
Flags: needinfo?(luesd)
I think this was fixed by bug 1193610.

julia breink, it would be much appreciated if you could test in an up-to-date version of Firefox 43 or later to see if the problem has been fixed. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193610
You need to log in before you can comment on or make changes to this bug.