Cube demo does not animate in latest nightly

RESOLVED DUPLICATE of bug 1210784

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1210784
2 years ago
2 years ago

People

(Reporter: birtles, Unassigned)

Tracking

({regression})

44 Branch
x86_64
Windows 10
regression
Points:
---

Firefox Tracking Flags

(firefox42 unaffected, firefox43 unaffected, firefox44- unaffected, firefox45 unaffected, firefox46 fixed)

Details

(URL)

(Reporter)

Description

2 years ago
The test URL animates smoothly in Firefox 42. However, it fails to update in latest nightly. When you scroll one of the panes we repaint but not otherwise.

This could be a regression from some of the refresh driver interaction I reworked in bug 1195180.
mozregression says this is another regression from bug 1097464.
Blocks: 1097464
status-firefox43: --- → affected
tracking-firefox43: --- → ?
tracking-firefox44: --- → ?
Keywords: regressionwindow-wanted
status-firefox42: --- → unaffected
status-firefox43: affected → unaffected
tracking-firefox43: ? → ---
Version: Trunk → 44 Branch

Comment 2

2 years ago
Tracking in Nightly because regression.
tracking-firefox44: ? → +
This appears to work OK with the patch from bug 1120784 applied locally.

Comment 4

2 years ago
Sinker, (based on comment 1) bug 1097464 is assigned to you and possibly caused this regression, would you be able to investigate and fix this bug? Thanks!
Flags: needinfo?(tlee)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)
> This appears to work OK with the patch from bug 1120784 applied locally.

This should have been bug 1210784, silly typo. I can confirm that this works correctly on trunk builds including that fix, so I'm duping it over there.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: --- → fixed
Flags: needinfo?(tlee)
Resolution: --- → DUPLICATE
Duplicate of bug: 1210784
At least, our behavior matches Chrome and older releases of Firefox. Edge has different behavior, but that could just as easily be a bug on their end. Given that our current behavior is consistent with what we used to do and what Chrome does, I think it's still reasonable calling this a dupe.

Comment 7

2 years ago
Given comment 5, I do not think we need to track this bug. Bug 1210784 is already tracked for FF44 so we are good.
tracking-firefox44: + → -
Bug 1097464 was backed out from Fx44, which should be available on the beta channel in the next day or so. Fx45+ remain affected, however.
status-firefox44: affected → unaffected
status-firefox45: fixed → unaffected
status-firefox46: --- → fixed
You need to log in before you can comment on or make changes to this bug.