B2G Gecko segfault because of target 0x0

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: gerard, Unassigned)

Tracking

({qablocker, regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8668417 [details]
gdb backtrace

Reproduced after flashing a new Gecko/Gaia:
 - gecko 9bd18a2bc788988edca8d24169385ddf64f668a7
 - gaia ca8abff50e8a5aba18397e67f0db28465efd1b36
(Reporter)

Comment 1

2 years ago
Still crashing after pulling latest gecko/gaia, rebuilding from scratch ...
(Reporter)

Comment 2

2 years ago
Created attachment 8668458 [details]
gdb backtrace
(Reporter)

Comment 4

2 years ago
Not reproduced when full flashing a Z3c with L build. Reproduced with my KK build updating existing profile.
(Reporter)

Comment 5

2 years ago
bisecting ...
(Reporter)

Comment 6

2 years ago
Looks like one of the triggering conditions is to have working network (crash started few seconds after a successfull wifi connection, and now in the train without wifi nor data I don't reproduce the crash at all).
(Reporter)

Comment 7

2 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #4)
> Not reproduced when full flashing a Z3c with L build. Reproduced with my KK
> build updating existing profile.

Hm that test was against a gecko tree that does not match the one that does reproduce the crash: e53dc84f5cf73046e29e5ff74f11571a63e56eba
(Reporter)

Comment 8

2 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #6)
> Looks like one of the triggering conditions is to have working network
> (crash started few seconds after a successfull wifi connection, and now in
> the train without wifi nor data I don't reproduce the crash at all).

I confirm this: with data enabled and connected, crash occurs as soon as we have network
See Bug 1210459, there's patch will fix cases that use nsILoadContext.
(Reporter)

Comment 10

2 years ago
Reverting bug 1165466 I don't have any crash at all.
Blocks: 1165466
Keywords: regressionwindow-wanted
(Reporter)

Comment 11

2 years ago
(In reply to Yoshi Huang[:allstars.chh] from comment #9)
> See Bug 1210459, there's patch will fix cases that use nsILoadContext.

I am testing a gecko with bug 1165466 and that new patch.
Self reminder to test
Flags: needinfo?(nhirata.bugzilla)
(Reporter)

Comment 13

2 years ago
So bug 1210459 landed, this is fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Flags: needinfo?(nhirata.bugzilla)
You need to log in before you can comment on or make changes to this bug.