Closed Bug 1210443 Opened 7 years ago Closed 7 years ago

German: Password manager does not save passwords

Categories

(SeaMonkey :: Passwords & Permissions, defect)

SeaMonkey 2.38 Branch
Unspecified
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1208971

People

(Reporter: RainerBielefeldNG, Unassigned)

Details

Steps how to reproduce with  German SeaMonkey 2.38  (Windows NT 6.1; WOW64; rv:41.0)  Gecko/20100101 Firefox/41.0 Build 20150923195647  (Classic Theme) on German WIN7 64bit:

1. Launch Browser
2. Menu 'Tools → Password Manager → into find string pane type a domain
   for what you know it's password and for what you stored a password
3. TAB "Passwords"
   » Domain with  stored password is shown
4. [Delete] that domain
5. go to website for what you deleted password and try to login 
   by typing your user name into user name input pane
   » Autofill might complete user name
6. Type password into password input line → <enter>
   » Login will be successful
   Expected: "Save Password?" message appears
   Actual: nothing happens, no message, password can not be stored

I found this problem during my tests for "Bug 1208971 After Update from 2.35: German Version Password-Manager does not populate password-fields", see <https://bugzilla.mozilla.org/show_bug.cgi?id=1208971#c10>

Additional information:
a) only native German Language SeaMonkey affected, en-US with German
   Language pack works fine
b) other Languages not yet tested.
c) also new password in newly created user profile does not work
c) due to comments at de.comm.software.mozilla.nightly-builds
   "[SM Aurora] Passwort speichern geht nicht" the problem might
   already be in Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 
   Firefox/39.0 SeaMonkey/2.36a2 Build identifier: 20150504013001
I can confirm this upgrading frpom 2.33.1 to 2.35 to 2.38 Windows x86

It also doens't work in my 2.39 beta:

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39

I see an error in the grman version wich I do not get in the us version:

>> Zeitstempel: 21.10.2015 08:57:11
>> Fehler: NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) >> [nsIPrefBranch.getCharPref]
>> Quelldatei: resource://gre/components/nsSuiteGlue.js
>> Zeile: 953

Didin't check it if this is the cause.

The good news is that it stops working even in the us version with 2.39:)

>> Timestamp: 21.10.2015 09:07:53
>> Error: NS_ERROR_FAILURE: Couldn't decrypt string
>> Source File: resource://gre/components/crypto-SDR.js
>> Line: 146

Need to check this over the weekend and open a new bug if necessary

FRG
With the patch in Bug 1208971 applied I can no longer reproduce this. The NS_ERROR_UNEXPECTED goes away when setting the spellchecker preference. The decrypt failure was a corrupt profile I think (too much testing with different versions). 

I think this bug is a duplicate of Bug 1208971 and not limited to Seamonkey 2.38

>> User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:42.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39
>> Build-Identifikator: 20151024102121
(In reply to Frank-Rainer Grahl from comment #3)
At least I can say that workaround for Bug 1208971  
<https://bugzilla.mozilla.org/show_bug.cgi?id=1208971#user_story_comment> also works here, these bugs are _very_ related.

DUP until someone proves the opposite.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
See Also: 1208971
You need to log in before you can comment on or make changes to this bug.