Closed Bug 121053 Opened 18 years ago Closed 17 years ago

[RFE] Separators need to support optional labels

Categories

(SeaMonkey :: Bookmarks & History, enhancement, P3)

x86
All
enhancement

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.4alpha

People

(Reporter: burton, Assigned: janv)

References

Details

It would be nice if separators could support labels.

So instead of just:

-------------------------------

we would see 

-- label: ---------------------

This would come in really handy when one wanted to have a folder with multiple
bookmarks without having to use sub-folders.

So for example we could have 

folder:
    -- label_1 --------------------
    bookmark_1
    bookmark_2
    -- label_2 --------------------
    bookmark_3
    bookmark_4

This would allow users to limit their bookmark nesting level.  I personally
don't like to have too many bookmark folders, maybe only 1 level.
confirming rfe
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Also.  This would require a UI change in the Bookmark manager.

When you right click on a separator you should be able to see a 'Properties'
option so that you can set the label.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Blocks: 196756
-> me
Assignee: ben → varga
Status: ASSIGNED → NEW
OS: Linux → All
Priority: -- → P3
Target Milestone: Future → mozilla1.4alpha
This is now supported in the 2003-03-25-03 Mach0 and 2003-03-25-04 Win32 trunk
builds. You can assigned name to a seperator via the properties contextual menu.
Fixed by bug 196756. Verified.

Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Verified.
Status: RESOLVED → VERIFIED
Build 2003032508 Win32 trunk

Was it so intended that I can see the label only in the Bookmark Manager and
Sidebar, but not in the dropdown bookmarks from the Personal Toolbar?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.