Globally define MOZILLA_OFFICIAL

VERIFIED FIXED in Firefox 43

Status

()

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Dolske, Assigned: Dolske)

Tracking

Trunk
Firefox 44
Points:
---

Firefox Tracking Flags

(firefox43 fixed, firefox44 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

3 years ago
*grumble* *grumble*

My fix for bug 1198525 didn't actually change anything. The contents of about:rights in Nightly and Aurora is still the unbranded flavor.

The cause is that despite MOZILLA_OFFICIAL being used in various places, it's only explicitly pulled out of the global config in _those_ places for use as a #define. This wasn't being done in toolkit/content/jar.mn, and so the #ifdef MOZILLA_OFFICIAL there never actually works. :(

This is kind of ridiculous, so I've changed it to be a global #define from autoconf, as opposed to being used piecemeal.
(Assignee)

Comment 1

3 years ago
Created attachment 8668709 [details] [diff] [review]
Patch v.1

I did a build with "export MOZILLA_OFFICIAL=1" in my mozconfig to confirm this actually fixes about:rights.
Assignee: nobody → dolske
Attachment #8668709 - Flags: review?(mh+mozilla)
Comment on attachment 8668709 [details] [diff] [review]
Patch v.1

Review of attachment 8668709 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/app/moz.build
@@ +28,5 @@
>  FINAL_TARGET_FILES.defaults.profile += ['profile/prefs.js']
>  
>  DEFINES['APP_VERSION'] = CONFIG['MOZ_APP_VERSION']
>  
> +for var in ('LIBXUL_SDK'):

python can be confusing. This is equivalent to for var in 'LIBXUL_SDK', which will iterate over each letter in the string. The right format for a tuple with 1 element would be ('LIBXUL_SDK',).
But since there is only one left, you might as well remove the loop.
Attachment #8668709 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 3

3 years ago
Created attachment 8669184 [details] [diff] [review]
Patch v.2

Fixed broken loop.
Attachment #8668709 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Attachment #8669184 - Attachment is patch: true
(Assignee)

Comment 5

3 years ago
Created attachment 8669206 [details] [diff] [review]
Patch for aurora

Fix trivial merge conflict for Aurora.

Approval Request Comment
[Feature/regressing bug #]: incomplete fix from bug 1198525
[User impact if declined]: incorrect text in about:rights
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: low, this makes official Nightly and Aurora builds have the same text that we ship on Beta and Release. (Developer builds will be unchanged.)
[String/UUID change made/needed]: n/a
Attachment #8669206 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/3e53831ea3df
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox44: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Comment on attachment 8669206 [details] [diff] [review]
Patch for aurora

Useful looking! Fixes about:rights, for now. Let's uplift to aurora.
Attachment #8669206 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 8

3 years ago
Current Nightly now has the expected text, so looks like this finally fixed it.
Status: RESOLVED → VERIFIED

Updated

3 years ago
Depends on: 1212889

Updated

3 years ago
No longer depends on: 1212889
You need to log in before you can comment on or make changes to this bug.