Status

()

defect
RESOLVED DUPLICATE of bug 1209464
4 years ago
4 years ago

People

(Reporter: aklotz, Unassigned)

Tracking

({hang, regression})

unspecified
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(firefox41- affected, firefox42+ affected, firefox43 affected, firefox44 affected)

Details

Attachments

(2 attachments)

(In reply to ffdixon from comment #25)

> Is there anyway to back out this change or quickly triage? 
> 

Is the crash reporter picking up these hangs? Any chance you can provide us with some URLs from about:crashes?
Flags: needinfo?(ffdixon)
Got it!

  https://crash-stats.mozilla.com/report/index/647e48a5-6aaf-4a2d-97ef-920742151002

Regards,... Fred
Flags: needinfo?(ffdixon)
That crash report appears to be a different issue, it's from Firefox 40.0.3, and is a couple months old.

It looks like there isn't a crash report created, because nothing is actually crashing - it's a hang (not accepting user input), not a crash.

Note that the entire Firefox window stops accepting input, not just the Flash client area.

Notably, there appears to be some things you can do to unhang Firefox - in particular, right-clicking on the Firefox taskbar and choosing "close window" seems to kick it, and you get the "You are about to close X tabs" dialog - which has the titlebar blink several times as it appears to be processing all of the buffered click events that had been done on the window while it was hung.
We just tested this on a Windows 7 Pro machine and were able to get FireFox 41.0.1 to freeze as well by the same method:

1.  Open http://demo.bigbluebutton.org/demo/demo2.jsp
2.  Enter any name 
3.  Click 'Join'
4.  Wait until the BigBlueButton client loads.
5.  Click 'Listen Only'
6.  Refresh page go to Step 4

After a few repeats, FireFox 41.0.1 on Windows 7 freezes.

Tested last night with 41.0.0 and couldn't get it to freeze, let it upgrade to 41.0.1, and it freezes/hangs almost immediately.
I tried to test this in Nightly, but 1) Once the page loads, pressing F5 no longer does anything - I guess the Flash content captures it? 2) If I refresh by clicking the refresh button in the address bar, it takes me to a page saying I need Flash installed to use it, and offering to redirect me to an HTML5 version.
I forgot to mention, that's with today's 32-bit Nightly (2015-10-02), and with Flash version 19.0.0.201, on 64-bit Windows 7.
(In reply to Calvin Walton from comment #3)
> It looks like there isn't a crash report created, because nothing is
> actually crashing - it's a hang (not accepting user input), not a crash.

Our crash reporter is capable of collecting reports for hangs under the right circumstances.
Is there anyway to cause FireFox to create a crash report?  One challenge is that when it hangs, it's not accepting any keyboard or mouse input, as shown in this video

  https://youtu.be/NzryyxQyvHo

We've left it frozen for a while, then quit us in the system tray (right-click and choose Close All Windows), but there isn't any entry in 

  about:crashes?

Is there any other way to trigger FireFox to create a crash report?  We'd like to get you whatever information we can.
Posted file crashfirefox.exe
You can run this utility that I built from:
https://github.com/bsmedberg/crashfirefox-intentionally

(README is available there)
Flags: needinfo?(ffdixon)
That worked like a charm.  Here's the crash report (I ran the .exe when FireFox 41.0.1 was frozen)

  https://crash-stats.mozilla.com/report/index/a701ec32-c073-4531-8860-2dc582151002
Flags: needinfo?(ffdixon)
We've tried a few different versions of Firefox, here's the summary:

FF 41.0: No Hang
FF 41.0.1: Hang
FF Beta 42.0b3 (20151001142456): No Hang
FF Aurora 43.0a2 (20151002004047): No Hang

So we can only reproduce the issue on 41.0.1 - not any of the newer versions.
Ah, spoke too soon - right as I submitted that message, we reproduced on the FF Beta 42.0b3 (20151001142456) build as well. It's kind of intermittent there. Still trying Aurora, and I'll see if I can pick up a Nightly build.
Unfortunately the crash report only returns data from the parent process. Can you run crashfirefox again but this time as:

crashfirefox <pid>

where pid is the process id of the plugin-container that is hosting Flash?
Flags: needinfo?(ffdixon)
Looks like something we may want to track.
Keywords: hang
It looks like the crash reporter didn't do a good job walking the stacks in the crash reports above, but I can reproduce this hang with the STR in comment 4. See attached stacks
Flags: needinfo?(aklotz)
We've noticed if the user has multiple tabs open they can unfreeze FireFox by clicking 'cancel' on the warn multiple tabs closing dialog box open. 

We demonstrate it in this video

  https://www.youtube.com/watch?v=8JKagSUMoOc

Hopefully this provides more clues that may lead to fixing the freeze.  Something is happening in the close multiple tabs dialog box that unfreezes FireFox.
Indeed, tracking as it is a recent regression.
[Tracking Requested - why for this release]: Nom'ing for 41.
Can you try this build and tell me if you're still able to reproduce?
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/aklotz@mozilla.com-ee278c419e02/try-win32/firefox-41.0.en-US.win32.installer.exe
Flags: needinfo?(ffdixon)
Hi Aaron,

Good news!  We can't reproduce the bug on the version you posted (I've tried for over 10 minutes).  And when I switch back to FireFox 41.0.1, it will freeze almost immediately.

How soon could this make its way into stable?  Is there anything we can do to help the process?
Flags: needinfo?(ffdixon)
You've done everything you can at this point, I just need to get it landed and approved for the various channels.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(aklotz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1209464
Don't need to track it as it's a dup. The other bug has 41:? so it will continue to show up as a real issue on RelMan's queries.
You need to log in before you can comment on or make changes to this bug.