Closed Bug 121104 Opened 23 years ago Closed 22 years ago

IMAP: can see only second level of public folders

Categories

(MailNews Core :: Networking: IMAP, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 138759

People

(Reporter: fedor, Assigned: sspitzer)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226
BuildID:    2001122617

When connecting to Exchange 5.5 or Exchange 2000 via IMAP both Mozilla 9.5, 9.6,
9.7 can see only the second level of Public Folders (but we have the 3, 4, 5 and
more).

Reproducible: Always
Steps to Reproduce:
1.Try to open the tree of Public Folders on Exchange 5.5 or 2000
2.
3.

Actual Results:  You can see the folders and messages only till the second level

Expected Results:  To see all the levels

When you try to subcribe to specific Public Folders Mozilla also shows only the
second level and some of the folders' names are displayed as "QWE3R34T34563E34R5YW"
KMail 1.3.1 shows the Public Folders correctly.
Evolution 0.9.5 - no.
Is this still a problem?

Having problems finding someone with IMAP access to Exchange...
in mozilla 1.0 RC1 it is still a problem
Confirmed on mozilla 1.1a, RH Linux 7.2

When opening the imap folder tree, mozilla only scans the first 2 levels and
shows deeper levels as if they were message folders (not subfolders).
When I close and reopen the innermost level, mozilla scans two more levels and
stops at the last one again.
Deleting msf files doesn't help.
This also keeps me from filing messages (via context menu or search dialog) in
deeper subfolders which I haven't opened yet in the current session. 

Reproducible: always
Reporter (Fedor Fantikov): Can you reproduce this with a recent Mozilla version
(like 1.1beta)? If not, please mark this bug as "worksforme".
The bug still exists in version 1.1b
I get this problem using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.0.1) Gecko/20020823 Netscape/7.0 when connecting to Exchange 5.5 on Windows
2000 so would seem to be a more general problem than just Linux
Marking NEW by independent confirmation in previous comment, adjusting OS.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
I can reproduce this with build 2002091014, cyrus imapd 2.1.5 and exchange 2000.
Seems to be independent of mail server. Also, it is not limited to public
folders, private folders are affected as well. Btw, if you create the folders
using mozilla,  everything works fine until you unsubsribe them and close the
subscription window. The next time you open it, you will only see them up to
depth 2 (plus the virtual "shared folders" folder, in case of public folders).
I can confirm this occurs when accessing a MailRelayer (www.mailrelayer.com)
IMAP server as well. It is definitely server-independant.
Additional background observations:
 - when I connect to my cyrus 2.x IMAP servers I can only see the top two levels
of public folders - UNLESS I have already subscribed to other deeper level
folders using Outlook (platform Windows NT).

This was with Netscape 7 (is the mail system borrowing information from
Outlook's settings to find out about the other folders?)
The bug persist on v 1.3a, build 2002112213. It was reported eleven months ago,
why can't it be re-assigned to someone who's not on sabbatical? 
Although implied, I don't see it in the comments, but this bug also affects mail
folders via IMAP.  If you have nested folders more than 2 levels deep on an
Exchange or any RFC-compliant IMAP server, you will not see the deep folders.

Interesting to note, however, is that the *very first time* mozilla hits this
mailbox (and presumably public folder server) it will allow you to see and
subscribe to those deeply nested folders.  After that, if you have not
subscribed, you will need to use some other IMAP client to get those folders.
QA Contact: huang → gchan
I am having this problem with 1.3b. I can subscribe to all the folders (more
than two levels deep) and can mark them for download/offline use; I can download
them and go offline with no problem; and I can see all the messages in all the
folders. However - when I go back online, Mozilla "forgets" all the folders more
than two levels deep, even deleting their message files. And when new mail comes
in, Moz disables any filters that filter messages to third or deeper level boxes.

Closing and opening a second level box will give me "twisties" for the third
level and subsequent boxes. But the messages are now all gone, and have to be
re-downloaded.

This is really frustrating, and is holding up our deployment of Mozilla. If we
can't get this fixed soon we're going to have to do with another IMAP client,
since our laptop users need access to their offline message when on the road.
Flags: blocking1.3+
Why was this marked blocking1.3+?
Summary: IMAP:can see only second level of public folders → IMAP: can see only second level of public folders
taking.

note to lpb+moz@kandl.houston.tx.us, you can request (use ?) for a blocker, but
drivers (like asa@mozilla.org) have to approve it (use +)
Assignee: mscott → sspitzer
Flags: blocking1.3+ → blocking1.3?
Flags: blocking1.3? → blocking1.3-
The summary is wrong and should be corrected. This problem is not limited to 
public mail folders. I get the same problem with my personal mail folders. 

Mozilla 1.2.1 Mail is only available to access folders at level 1 and 2 
beneath my mail root (personal mail folders):
  Inbox          OK: Read messages
  2fo/Div        OK: Read messages
  Div/Ugh        OK: Read messages
  Div/Firmaer/   Problem: Subfolders can not be seen, content not accessible,
                          folder not expandable

I agree with the last paragraph of Additional Comment #13 From 
lpb+moz@kandl.houston.tx.us and Additional Comment #11 From Zenon Panoussis


Background information
----------------------
Client OS Microsoft Windows XP Professional SP1 English

IMAP server: telnet imap.uib.no imap:
* OK [CAPABILITY IMAP4REV1 X-NETSCAPE LOGIN-REFERRALS AUTH=LOGIN] alf.uib.no 
IMAP4rev1 2002.330 at Thu, 13 Mar 2003 23:45:47 +0100 (MET)

IMAP folder hierarchy created and accessible with the following IMAP clients:
- Netmanage Z-Mail Pro v. 6.2
- Pegasus Mail V4.02a (Win32)
- horde IMP Webmail Client (3.x?) (webmail.uib.no) running in
  - Mozilla 1.2.1
  - Microsoft Internet Explorer 6.0.2800.1106.xpsp1.020828-1920

Ole-Henrik.Edland@mfr.uib.no
Flags: blocking1.4a?
Flags: blocking1.4a? → blocking1.4a-

*** This bug has been marked as a duplicate of 138759 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
This is a dupe of bug 138759, please update your votes.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.