Provide a means (e.g. about:config) for overriding Android's screen size and DPI info

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: netrolller.3d, Unassigned)

Tracking

41 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I'm using Firefox on Android, and have just switched from a Galaxy S III to a Galaxy Note 4. Firefox's UI doesn't  scale correctly on this device: instrad of UI elements having the same size as on the S III, with more space to lay them out; the layout is scaled up and UI elements are simply larger. In other words, instead of treating this screen as a larger viewport with similar DPI, it's treated as the same viewport with increased DPI.

Another device of mine, a 7-inch Navon tablet, inappropriately gets treated as a phone and given a small-screen UI.

I would like to have a means to override this (there's Xposed App Settings, but that requires root and doesn't  work well with Firefox). I tried setting layout.css.devPixelsPerPx to a custom value, but that only scales content, not chrome (unlike on Windows). It would also be nice to force tablet UI (with back/forward buttons and tab bar) on a device detected as a phone, and vice versa - this used to be possible with Xposed App Settings until around Firefox 28 or 29, but now crashes if tried; plus, it should be possible without root as well.
(Reporter)

Comment 1

3 years ago
I forgot to add, the Note 4 is an octa-core running the official 5.1.1 firmware for Hungary; the Navon tablet is on the firmware it shipped with (4.1.2).
For some history, bug 1024717 should hopefully fix the Xposed App Settings crashing (which may be the cause of bug 1079874).

I'm not sure if we'd support this as an app feature because applications like ^ exist for those who really want it and it would take extra development effort to support.
See Also: → bug 1024717
(Reporter)

Comment 3

3 years ago
This feature should not requure voiding my warranty. Also, this is a platform parity issue, since the same feature works perfectly on Windows, where chrome and content both scale nicely with layout.css.devPixelsPerPx, while only content is scaled on Android.
(In reply to Gábor Stefanik from comment #3)
> This feature should not requure voiding my warranty. Also, this is a
> platform parity issue, since the same feature works perfectly on Windows,
> where chrome and content both scale nicely with layout.css.devPixelsPerPx,
> while only content is scaled on Android.

Firefox on Android is a completely native Android UI. We do not use Gecko to render the chrome UI. We use Android mechanisms for displaying the native widgets at the required DPIs.

I don't think we can implement this feature. Even if we could try, I don't think I'd want to spare the people to do it. I'm WONTFIXing this bug. There is just no way to make this work.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.