Downloads don't show up in download manager on Fennec

VERIFIED FIXED in Firefox 42

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: JanH, Assigned: Gijs)

Tracking

({regression})

42 Branch
mozilla44
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 unaffected, firefox42+ verified, firefox43 verified, firefox44 verified, fennec42+)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
After starting a download, it doesn't show up in the download manager any more.
If I have the download manager open while starting a download, it shows up, but if I later close and then re-open it, the download is missing again.

The regression window points to bug 1009795:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=10a4c5fbcca7d515fa287f89892fdd4c5e9a243e&tochange=cb7008d633835fa982492646de3cc191293fc28a

After having completed a new download and opening the download manager, the following error appears in the console:
> 14:25:32.345 Intl is not defined1 DownloadUtils.jsm:486:0
Reporter

Updated

4 years ago
Summary: Downloads don't show up in download manager → Downloads don't show up in download manager on Fennec
Assignee

Comment 1

4 years ago
[Tracking Requested - why for this release]:
Broken download things in Fennec


Ehsan, should this have used typeof instead?

Nick, why did tests not catch this? :-(
Flags: needinfo?(nalexander)
Flags: needinfo?(ehsan)
> Nick, why did tests not catch this? :-(

Was this intended for me?  I haven't any specific knowledge of this code, or the tests surrounding it.
Flags: needinfo?(nalexander)
Assignee

Comment 3

4 years ago
(In reply to Nick Alexander :nalexander from comment #2)
> > Nick, why did tests not catch this? :-(
> 
> Was this intended for me?  I haven't any specific knowledge of this code, or
> the tests surrounding it.

Yes. I was assuming we have automated tests for downloading files on Fennec. Do we not? Is that hard for some reason? It sounds like we should have tests (quite independent of DownloadUtils.jsm itself).
ugh, yeah, a typeof check would be better there, sorry for not catching that.
Assignee

Comment 5

4 years ago
Posted patch Trivial patchSplinter Review
I tested this on my local android device, and it does make downloads show up again.
Attachment #8669625 - Flags: review?(paolo.mozmail)
Assignee

Updated

4 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(ehsan)
Recent regression, tracking. We want to fix in 42.
Attachment #8669625 - Flags: review?(paolo.mozmail) → review+
Assignee

Comment 8

4 years ago
Comment on attachment 8669625 [details] [diff] [review]
Trivial patch

Approval Request Comment
[Feature/regressing bug #]: l10n fix to downloads code
[User impact if declined]: broken about:downloads / download manager on fennec
[Describe test coverage new/current, TreeHerder]: tests on desktop but apparently not on fennec...
[Risks and why]: one-line JS change that's pretty low-risk. Can't get any worse than totally busted!
[String/UUID change made/needed]: nope
Attachment #8669625 - Flags: approval-mozilla-beta?
Attachment #8669625 - Flags: approval-mozilla-aurora?

Updated

4 years ago
Duplicate of this bug: 1201512

Updated

4 years ago
tracking-fennec: ? → 42+
Sorry for the bustage and thanks for the quick fix, Gijs.

/me will learn js some day...  :/
https://hg.mozilla.org/mozilla-central/rev/9c7b48221853
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Comment on attachment 8669625 [details] [diff] [review]
Trivial patch

Sure, we want it! Should be in 42 beta 6.
Attachment #8669625 - Flags: approval-mozilla-beta?
Attachment #8669625 - Flags: approval-mozilla-beta+
Attachment #8669625 - Flags: approval-mozilla-aurora?
Attachment #8669625 - Flags: approval-mozilla-aurora+
Reporter

Comment 14

4 years ago
Verified with today's Nightly (build 20151008030232).
Status: RESOLVED → VERIFIED

Comment 16

4 years ago
Verified as fixed on latest Aurora and Firefox 42 Beta 6.
You need to log in before you can comment on or make changes to this bug.