Closed Bug 1211388 Opened 6 years ago Closed 6 years ago

Lockscreen: date/time overlaps notifications in RTL

Categories

(Firefox OS Graveyard :: General, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pelloux, Unassigned)

References

Details

(Whiteboard: [2.5-rtl-test-run])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151004004023

Steps to reproduce:

* Make sure you have a pending notification.
* "Open" the lockscreen with the phone configure to use the arabic locale.


Actual results:

Date/time display is overlapping the first notification.



Expected results:

Proper separation between date/time header and notifications block
Forgot to add: I'm testing using master and a Flame device.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looking at the screenshot I'm wondering if it's possible that mozIntl fails to remove the ampm portion of the time string.
I reported it as bug 1215068 because I'm not sure if it's the scope of this bug.
Whiteboard: [2.5-rtl-test-run]
Zibi: I believe the am/pm is the root issue here. If they are removed the overlap will most certainly disappear.
Probably worth adding bug 1215068 as a dependency of this one. wdyt?
Triage: looks awful, P1
Priority: -- → P1
This will be less visible (but not fixed in all gecko/gaia language combinations) when we get bug 1208808 fixed.
Depends on: 1208808
Hi Pierre-eric, 
Since bug 1208808 is fixed. Could you try again and see whether this issue is happen again?
Flags: needinfo?(pierre-eric)
Hi Lancy,
Can you check whether this bug is still exist on 2.5?
Thanks
Flags: needinfo?(yulan.zhu)
Hi Josh,
I can reproduce this issue on latest Flamekk v2.5 build once, date/time display is overlapping the first notification on the lockscreen. But it cannot be reproduced on latest AriesKK v2.5.
Flame Reproducing rate:1/50
Aries Reproducing rate:0/50
See attachment:Verify1_time on lockscreen_FlameKK v2.5.png

Device: FlameKK v2.5 (512mb) 
Build ID               20151108004501
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151108.045623
Firmware Date          Sun Nov  8 04:56:35 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: AriesKK v2.5 build
Build ID               20151107112205
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151107.104119
Firmware Date          Sat Nov  7 10:41:27 UTC 2015
Bootloader             s1
Flags: needinfo?(yulan.zhu) → needinfo?(jocheng)
QA Whiteboard: [MGSEI-Triage+]
Can still reproduce the issue.
Note that this issue depends on the time so to reproduce easily: manually configure your phone to "11.11 AM"
Flags: needinfo?(pierre-eric)
We did not fix bug 1215068 yet which blocks this bug.
Flags: needinfo?(jocheng)
This should be fixed now on master. Can someone test pls?
As far as I can test it's fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.