Closed Bug 1211456 Opened 4 years ago Closed 4 years ago

Contextual menu can no longer be used to set a one-click search engine as default

Categories

(Firefox :: Search, defect)

44 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 44
Tracking Status
firefox44 --- verified

People

(Reporter: petruta.rasa, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(1 file)

Reproduced with Nightly 44.0a1 2015-10-04 under Win 7 64-bit and Mac OS X 10.9.5

Steps to reproduce:
1. Select the search bar magnifying glass to open the search panel
2. Right click on a one-click search engine
3. Select "Set As Default Search Engine" from the Contextual Menu

Expected results:
The default search engine is modified, the panel is updated 

Actual results:
Regression, the search engine is not set as default. 
The following error is shown in browser console: TypeError: PlacesUtils.getImageURLForResolution is not a function
   onxblcommand()  search.xml:1448:19

Regression-range:
Last good revision: 096c0f407f8ba3ef7cfe4e0b831761993cac38b1 (2015-10-01)
First bad revision: 5f16c6c2b969f70e8da10ee34853246d593af412 (2015-10-02)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=096c0f407f8ba3ef7c
fe4e0b831761993cac38b1&tochange=5f16c6c2b969f70e8da10ee34853246d593af412

Inbound shows bug 1118926 as culprit (ran mozregression twice as it doesn't seem related, but I'm adding it so it can be reviewed):
Last good revision: d7ba52bbc272d5207768e2c9adef6ed863d5bfa1
First bad revision: f82ed42b855dfd2e87508134fbc84d9bc22ebce5
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d7ba52
bbc272d5207768e2c9adef6ed863d5bfa1&tochange=f82ed42b855dfd2e87508134fbc84d9bc22e
bce5
I don't understand what the point of this field is, because the one caller doesn't use 'this.' to use it, and I couldn't find callers outside the file, so I removed it. If I missed something, please let me know.
Attachment #8669688 - Flags: review?(florian)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8669688 [details] [diff] [review]
remove usage of getImageURLForResolution from search component,

(In reply to :Gijs Kruitbosch from comment #1)

> I don't understand what the point of this field is, because the one caller
> doesn't use 'this.' to use it

I think it's an XBL quirk that makes 'this.' implicit in code inside <handler> tags. I've never seen this documented, but observed this behavior a few times.
Attachment #8669688 - Flags: review?(florian) → review+
https://hg.mozilla.org/mozilla-central/rev/8885b50eda85
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Flags: qe-verify+
Confirming this fix on Firefox 44.0b4, build ID: 20151228134903.
Verified on Windows 7 64bit, Windows 8.1 64bit, Mac OS X 10.9.5 and Ubuntu 12.04 x86.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
QA Contact: cornel.ionce
You need to log in before you can comment on or make changes to this bug.