Closed Bug 1211487 Opened 6 years ago Closed 6 years ago

OMTA can affect the visible region of a ContainerLayer, but doesn't adjust it

Categories

(Core :: Graphics: Layers, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1208829
Tracking Status
firefox44 --- affected

People

(Reporter: mstange, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

Steps to reproduce:
 1. Load the testcase.
 2. Move your mouse over the black rectangle.
 3. Watch the blue circle be clipped away when it moves downwards.

This clipping happens when the ContainerLayer for the opacity draws its contents to an intermediate surface (which is required for group opacity): The intermediate surface is sized to the visible region of the ContainerLayer, and that visible region was calculated on the main thread by FrameLayerBuilder with the pre-animation child layer transforms in mind.

APZ has a similar problem.

I think we need to add a pass to LayerManagerComposite that throws away the visible region of each ContainerLayer and recomputes it, respecting the current transforms that have been updated by OMTA and APZ.
Attached file testcase
This is fixed by the patches in bug 1208829.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208829
You need to log in before you can comment on or make changes to this bug.