Closed Bug 1211636 Opened 4 years ago Closed 4 years ago

Nightly crash in mozilla::ipc::FatalError(char const*, char const*, unsigned long, bool) | mozilla::net::PNeckoParent::FatalError(char const* const) | mozilla::net::PNeckoParent::Read(mozilla::ipc::ContentPrincipalInfo*, IPC::Message const*, void**)

Categories

(Core :: DOM: Content Processes, defect, critical)

44 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla44
Tracking Status
e10s + ---
firefox44 --- verified

People

(Reporter: alice0775, Assigned: allstars.chh)

References

Details

(Keywords: crash, reproducible)

Crash Data

Attachments

(1 file, 1 obsolete file)

[Tracking Requested - why for this release]:

This bug was filed from the Socorro interface and is 
report bp-0ad4d743-a8ff-4097-9932-7836e2151005.
=============================================================

Reported http://forums.mozillazine.org/viewtopic.php?p=14355143#p14355143

STR
Open http://e-fibank.bg

Regression window:
https://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=e843ef367f3535bdb675f6afd501ac8b8d0220d&tochange=27576be038ea

Regressed by:
27576be038ea	Yoshi Huang — Bug 1167100 - User originAttribute in ContentPrincipalInfo. r=bholley
Flags: needinfo?(allstars.chh)
tracking-e10s: --- → ?
Thanks,
I found the problem is that appId is type of uin32_t from WebIDL, however in CreateSuffix and PopulateFromSuffix, we use nsString.AppendInt and nsString.ToInteger to handle it , which takes *int32_t*, will have a patch and a test case (maybe gtest) for this.
Assignee: nobody → allstars.chh
Flags: needinfo?(allstars.chh)
Attachment #8670151 - Flags: review?(bobbyholley)
Comment on attachment 8670151 [details] [diff] [review]
Patch. v1

Review of attachment 8670151 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, especially the test!

This is actually the same bug as bug 1203979, but it also handles userContextId which is great. Feel free to dupe that bug to this one.

::: caps/BasePrincipal.cpp
@@ +119,5 @@
>                           const nsString& aValue) override
>    {
>      if (aName.EqualsLiteral("appId")) {
>        nsresult rv;
> +      mOriginAttributes->mAppId = aValue.ToInteger64(&rv);

Please make this:

int64_t val = aValue.ToInteger64(&rv);
NS_ENSURE_SUCCESS(rv, rv);
NS_ENSURE_TRUE(val <= UINT32_MAX, NS_ERROR_FAILURE);
mOriginAttributes->mAppId = static_cast<uint32_t>(val);

Here and below.
Attachment #8670151 - Flags: review?(bobbyholley) → review+
Duplicate of this bug: 1203979
(In reply to Bobby Holley (:bholley) from comment #3)
Thanks for the review.

> int64_t val = aValue.ToInteger64(&rv);
> NS_ENSURE_SUCCESS(rv, rv);
Will change to NS_ENSURE_SUCCESS(rv, false);
since this function returns bool.

> NS_ENSURE_TRUE(val <= UINT32_MAX, NS_ERROR_FAILURE);
NS_ENSURE_TRUE(val <= UINT32_MAX, false);
Attached patch Patch. v2Splinter Review
addressed bholley's comment.
Attachment #8670151 - Attachment is obsolete: true
Attachment #8670596 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/f60288aebcc7
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Reproduced the bug in 44.0a1 (2015-10-05) on windows 10 x64

Verified as fixed with latest firefox aurora 44.0a2 (Build ID: 20151210004006)

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
QA Whiteboard: [testday-20151211]
Based on comment 10 and based on the details from Soccoro where no reports were found in the last 14 days, marking this bug as Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.