Closed Bug 1211884 Opened 7 years ago Closed 6 years ago

The tools menu from the pdf.js page is not dismissed by clicking on the toolbar

Categories

(Firefox :: PDF Viewer, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 49
Tracking Status
firefox41 --- affected
firefox42 --- affected
firefox43 --- affected
firefox44 --- affected
firefox49 --- verified

People

(Reporter: mboldan, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-ux][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7266)

Reproducible with 42.0b4 (20151005144425), 44.0.a1 (20151005030206)
Affected platforms: Windows 8.1 x64, Ubuntu 14.04 x86 and Mac OS X 10.11

Steps to reproduce:
1. Launch Firefox and open a random pdf file.
   e.g. http://cp.literature.agilent.com/litweb/pdf/5989-8139EN.pdf
2. Click on the Tools button from the toolbar.
3. Click on the toolbar or on a button from the toolbar (e.g. Print).

Expected results:
The Tools menu is dismissed.

Actual:
The Tools menu is not dismissed.

Additional notes:
1. If clicking outside the toolbar, the tools menu is dismissed. 
2. This issue is reproducible 100%.
3. This is not a regression as it's also reproducible all the way back to Firefox 26.0 (20131205075310), where the Tools menu was first introduced.
Priority: -- → P3
Whiteboard: [pdfjs-c-ux]
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 1268706
Resolution: --- → FIXED
Whiteboard: [pdfjs-c-ux] → [pdfjs-c-ux][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7266
Target Milestone: --- → Firefox 49
The issue is no longer reproducible on Firefox 49.0a1 (2016-05-08) and on Windows 10 x86, Mac OS x 10.8.5 and on Ubuntu 14.04 x86.
I am marking this issue Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.