500 ISE when committing an import with a deleted row

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jwhitlock, Unassigned)

Tracking

Details

(Whiteboard: [bc:infra][bc:milestone=bicycle])

(Reporter)

Description

3 years ago
What did you do?
================
1. Login as user with import-mdn permission
2. Go to https://browsercompat.herokuapp.com/importer/651
3. Select commit

What happened?
==============
A 500 error was returned.  The error email contains a traceback:

AssertionError: When looking up "feature.slug", could not find ID '6963' in features.

Feature 6963 is the "Basic Support" feature, which has been merged into the parent feature.

What should have happened?
==========================
The page should have imported without error, maybe with an option to delete the removed row.

Is there anything else we should know?
======================================
The import may work after manually deleting feature 6963, but encountered another 500 ISE, similar to bug 1159295
(Reporter)

Comment 1

3 years ago
Probably the same root cause as bug 1159317
Component: General → BrowserCompat
Keywords: in-triage
(Reporter)

Comment 2

3 years ago
The page imports after 1) manually deleting feature 6963, and 2) fixing bug 1159295 and bug 1159317.  Manual deletion may still be required when removing a row from an MDN page.
Blocks: 996570
Severity: normal → major
Keywords: in-triage
OS: Other → All
Whiteboard: [specification][type:bug] → [bc:infra]
(Reporter)

Updated

3 years ago
Blocks: 1240757
No longer blocks: 996570
Whiteboard: [bc:infra] → [bc:infra][bc:milestone=bicycle]
(Reporter)

Comment 3

3 years ago
This has not returned in follow-up imports, calling it fixed with bug 1159317 in https://github.com/mdn/browsercompat/commit/9cd7939b5687a632c81f5797495a389a4537f056
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Severity: major → normal
You need to log in before you can comment on or make changes to this bug.