[TV 2.5] Apply visual spec to the client-side page of TV remote control

RESOLVED FIXED

Status

Firefox OS
Gaia::TV
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: lchang, Assigned: lchang)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Apply visual spec to the client-side page of TV remote control.

Comment 1

2 years ago
Created attachment 8684844 [details] [review]
[gaia] luke-chang:1212403_remote_control_client_visual > mozilla-b2g:master
(Assignee)

Comment 2

2 years ago
Comment on attachment 8684844 [details] [review]
[gaia] luke-chang:1212403_remote_control_client_visual > mozilla-b2g:master

Hi Rex,

Could you please have a look at this patch?

Please refer to [1] for the Visual Spec. Besides, I modified a few behaviors on PIN-Code input fields due to compatibility issues on various browsers.

Thanks.

[1] http://bit.ly/1jrWQU3
Attachment #8684844 - Flags: review?(rexboy)
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
Comment on attachment 8684844 [details] [review]
[gaia] luke-chang:1212403_remote_control_client_visual > mozilla-b2g:master

r=me!
Attachment #8684844 - Flags: review?(rexboy) → review+
(Assignee)

Updated

2 years ago
Blocks: 1223387
(Assignee)

Comment 4

2 years ago
Rex, Thanks for your review.


tests passed: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=c010e247fe3784656ba40011661e2898a98b99e8

landed on master: https://github.com/mozilla-b2g/gaia/commit/e6e6b3ab3bcf04431300d5c472f89771380baa02
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [partner-cherry-pick]
(Assignee)

Comment 5

2 years ago
Comment on attachment 8684844 [details] [review]
[gaia] luke-chang:1212403_remote_control_client_visual > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1205939 [meta] TV Remote Control.
[User impact] if declined: Remote Control feature on TV isn't completed.
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): Low risk since this patch only affect TV build.
[String changes made]: Yes, but TV team will take care of this.
Attachment #8684844 - Flags: approval-gaia-v2.5?
I've just noticed that the icons that were introduced with this commit have not been compressed. They take over a MB of space whereas they should only take ~1KB each. Please run the compression script in the gaia tools and commit the compressed images instead (you'll need the optipng and advancecomp/advpng packages installed). From the gaia root directory execute the following command:

./tools/png_recompress.sh -v \
    tv_apps/remote-control-client/style/images/btn_back.png \
    tv_apps/remote-control-client/style/images/btn_home.png \
    tv_apps/remote-control-client/style/images/btn_option.png \
    tv_apps/remote-control-client/style/images/scrollbar.png

Comment 7

2 years ago
Created attachment 8687521 [details] [review]
[gaia] mozilla-b2g:revert-33067-1212403_remote_control_client_visual > mozilla-b2g:master
(Assignee)

Comment 8

2 years ago
Hi Gabriele,

Thanks for your reminder.

I've backout'ed my patch: https://github.com/mozilla-b2g/gaia/commit/feccab8e9e326ff999852a63a269fdbb2dbb311a

And will re-land it with compressed images.

Comment 9

2 years ago
Created attachment 8687523 [details] [review]
[gaia] luke-chang:1212403_remote_control_client_visual > mozilla-b2g:master
(Assignee)

Comment 10

2 years ago
Re-landed: https://github.com/mozilla-b2g/gaia/commit/4e95ab738ba8428198587fa7ee339943152f4fa2
(Assignee)

Updated

2 years ago
Attachment #8684844 - Flags: approval-gaia-v2.5?
(Assignee)

Updated

2 years ago
Attachment #8687521 - Attachment is obsolete: true
(Assignee)

Comment 11

2 years ago
Comment on attachment 8687523 [details] [review]
[gaia] luke-chang:1212403_remote_control_client_visual > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1205939 [meta] TV Remote Control.
[User impact] if declined: Remote Control feature on TV isn't completed.
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): Low risk since this patch only affect TV build.
[String changes made]: Yes, but TV team will take care of this.
Attachment #8687523 - Flags: approval-gaia-v2.5?

Updated

2 years ago
blocking-b2g: --- → 2.5+

Updated

2 years ago
Attachment #8687523 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+

Comment 12

2 years ago
Approve as required for TV 2.5

Updated

2 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed
Whiteboard: [partner-cherry-pick] → [ft:conndevices][partner-cherry-pick]
for 2.5 https://github.com/mozilla-b2g/gaia/commit/c9aa052db624d657e47cd7b494299397cf72b719
status-b2g-v2.5: affected → fixed
You need to log in before you can comment on or make changes to this bug.