[Raptor] Raptor fails to run coldlaunch tests for v2.2 branch

RESOLVED FIXED in FxOS-S9 (16Oct)

Status

Firefox OS
Gaia::PerformanceTest
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: azasypkin, Assigned: Eli)

Tracking

unspecified
FxOS-S9 (16Oct)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Created attachment 8670889 [details]
log output

When I try to run raptor coldlaunch tests for sms app on v2.2 branch, raptor always fails on the second run with "Polling socket recv() timeout!" (see logs attached).

I've tried to bisect and found out that it works fine for raptor@1.4.4 and fails for raptor@1.4.5+ (including v2.0.3).

Tests are run on the latest v2.2 PVT engineering build for Flame:
* Build Identifier: 20151007032507
* Git Commit Info: 2015-10-07 13:05:24, 885647d9
(Reporter)

Updated

2 years ago
See Also: → bug 1197231
(Assignee)

Comment 1

2 years ago
Created attachment 8671662 [details] [review]
Link to Github pull-request: https://github.com/mozilla-raptor/raptor-cli/pull/28
Attachment #8671662 - Flags: review?(rwood)

Comment 2

2 years ago
Comment on attachment 8671662 [details] [review]
Link to Github pull-request: https://github.com/mozilla-raptor/raptor-cli/pull/28

LGTM
Attachment #8671662 - Flags: review?(rwood) → review+
(Assignee)

Comment 3

2 years ago
In master: https://github.com/mozilla-raptor/raptor-cli/commit/fbb3fabf7e366ab589db0a20987004ac9481b82d
In npm: @mozilla/raptor v3.0.1
Assignee: nobody → eperelman
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe]
Target Milestone: --- → FxOS-S9 (16Oct)
You need to log in before you can comment on or make changes to this bug.