[PP]Crash a lot using Messenger on my Mac

VERIFIED FIXED in M11

Status

MailNews Core
Backend
P1
critical
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: esther, Assigned: Kathleen Brade)

Tracking

Trunk
PowerPC
Mac System 8.5
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using mac build 19990816 on my PPC 8500, OS 8.5 I crash a lot using Messenger,
and can't really get steps.   I will log a talkback incident each time and put
this bug number in the description.   After several crashes I'll update this bug
with the incident numbers so we can see if the crashes are all in the same area.

Steps (at this time, will update when I have more specific reproducible steps)

1. Launch Messenger and use it.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → esther

Updated

18 years ago
Assignee: phil → esther

Comment 1

18 years ago
Reassign to esther to develop steps
(Reporter)

Comment 2

18 years ago
OK, here are the incidents: 12624061,12623088, 12622587, 12622167, 12621950,
12621601, 12615467, 12613859, 12612214.
What they all have in common is closing the 3-pane messenger window after having
a Mail Compose or Editor window was opened at least once while the 3-pane window
was opened.  Mail Message windows include: New Msg, Reply or Forward window in
HTML or Plain text.

Here is a simple scenario, I will add the stack from the talkback this
simple case produces 12624474).

1. Launch Messenger (don't launch apprunner first, messenger only)
2. Select New Msg toolbar button
3. File|Close the New Msg window
4. File|Close the 3-pane window
Crash

Call Stack:    (Signature = 0x619a6198 6aa2893c)
0x619a6198
EditorCore.shlb + 0x1ba40 (0x0ce2f170)
EditorCore.shlb + 0x737c (0x0ce1aaac)
EditorCore.shlb + 0x1bec8 (0x0ce2f5f8)
nsCOMPtr_base::~nsCOMPtr_base()
[nsCOMPtr.cpp, line 26]
EditorCore.shlb + 0x3ef58 (0x0ce52688)
EditorCore.shlb + 0x3f060 (0x0ce52790)
XPConnect.shlb + 0x14b64 (0x0d029be4)
XPConnect.shlb + 0x1421c (0x0d02929c)
XPConnect.shlb + 0x14338 (0x0d0293b8)
XPConnect.shlb + 0x18934 (0x0d02d9b4)
js_FinalizeObject()
[jsobj.c, line 1259]
js_GC()
[jsgc.c, line 831]
js_ForceGC()
[jsgc.c, line 610]
JS_GC()
[jsapi.c, line 1073]
DOM_DLL + 0x4ff0 (0x0d7890b0)
DOM_DLL + 0xe950 (0x0d792a10)
layout.shlb + 0x272dd0 (0x0d3326b0)
layout.shlb + 0x272acc (0x0d3323ac)
nsWebShell::Destroy()
[nsWebShell.cpp, line 1206]
nsWebShell::DestroyChildren()
[nsWebShell.cpp, line 773]
nsWebShell::Destroy()
[nsWebShell.cpp, line 1209]
(Reporter)

Updated

18 years ago
Assignee: esther → phil
(Reporter)

Comment 3

18 years ago
Note: this does not happen on Win98 and Linux, mac only using M9 builds.
Also note using the same scenario but selecting Editor or Plain Text editor from
the Tasks menu instead of New Msg will crash too.  I think this is an Ender
problem.

Updated

18 years ago
Assignee: phil → buster

Comment 4

18 years ago
Yep, looks like Ender on the top of the stack. Reassigning to buster.

Comment 5

18 years ago
cc: sujay.

Updated

18 years ago
Assignee: buster → brade
Priority: P3 → P1
Target Milestone: M11

Comment 6

18 years ago
assigned to kathy, cc simon and joe.  Please decide among the 3 of you who has
time to look into this one.  Very high priority.

Updated

18 years ago
Blocks: 11091

Comment 7

18 years ago
(target milestone is M11 or M12 - add to mail beta tracking bug)
(Assignee)

Updated

18 years ago
Depends on: 14396
Summary: [PP]Crash a lot using Messenger on my Mac-will collect Talk Back incidents. → [PP]Crash a lot using Messenger on my Mac
(Assignee)

Comment 8

18 years ago
unable to reproduce due to bug #14396
(Assignee)

Updated

18 years ago
Depends on: 14146
No longer depends on: 14396
(Assignee)

Comment 9

18 years ago
fix dependency bug # for tracking purposes
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

18 years ago
resolve as fixed.  this worksforme.  Esther: please verify.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

18 years ago
Using 1999100118 build on mac this is working for me now.  Verified
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.