Closed Bug 1212875 Opened 6 years ago Closed 6 years ago

text-align not applied for [dir="auto"][contenteditable="true"] empty element.

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1103011
Tracking Status
firefox41 --- affected
firefox44 --- affected
b2g-master --- affected

People

(Reporter: autra, Unassigned, NeedInfo)

References

Details

Attachments

(1 file)

Attached file test case
[Step]
- click on the "test case" attachment.
- focus the contenteditable="true" element, ie the grey box at the end of the page
- observe the caret position

[Expected]
- As this element has a `text-align="right"` the caret should be on the right.

[Actual]
- The caret is on the left, and jumps to the right as soon as we begin typing.
See Also: → 1103011
Hey Julien, this test case is basically a stripped down version of the .recipient[contenteditable] of the sms app. I thought you might want to see this.

I'm filling this bug because, although the symptoms are the same, I couldn't reproduce with the example in https://bugzilla.mozilla.org/show_bug.cgi?id=1103011 any more.

If this get fixed, we might be able to get rid of all the workaround in recipients.css \o/
Flags: needinfo?(felash)
also NI Simon, as he was the assignee for bug 1103011.
Flags: needinfo?(smontagu)
I think you can just attach this attachment in bug 1103011 and obsolete the old one. Then dupe this bug there.

I still see weird things with the old one (for exemple using "suppr" with the caret at "start", the caret moves, but shouldn't), but I agree with you, the issue is not that apparent anymore on the old testvcase.
Flags: needinfo?(felash)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1103011
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.