Don't run (desktop) tests as root

RESOLVED DUPLICATE of bug 1213325

Status

Taskcluster
Docker Images
RESOLVED DUPLICATE of bug 1213325
2 years ago
2 years ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

Details

(Assignee)

Description

2 years ago
Docker-worker currently runs tasks as root, but we don't want that for desktop tests, at least.

There's a workaround in place in testing/docker/desktop-build/bin/build.sh which switches users before doing anything else.  We could easily do something similar for tests.

The question is, do we want to make this change for all users of the 'tester' image, or make it optional, or use a different image for desktop and B2G.
(Assignee)

Comment 1

2 years ago
I want to do bug 1213325 first, as that will bring the test scripts in line with the build scripts and make this feature easier.
Depends on: 1213325
(Assignee)

Updated

2 years ago
Blocks: 1171033
(Assignee)

Comment 2

2 years ago
Actually, bug 1213325 accomplished this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213325
You need to log in before you can comment on or make changes to this bug.