[Music][NGA] Remove A-Z picker until we have a UX spec for additional locales

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: justindarc, Assigned: justindarc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Based on in-depth conversation on IRC today regarding sorting music in locales other than en-US, we have concluded that the A-Z picker should be removed until we have a UX spec/solution for other locales.

From #fxos:

14:54 gandalf: nefzaoui_: can you help us?
14:54 justindarc: we just need a reasonable default that makes sense for most
14:54 gandalf: in Arabic UI, list of songs
14:54 gandalf: how would you like the groupings to look like
14:54 gandalf: and sorting?
14:54 gandalf: for english song titles+ arabic song titles
14:54 nefzaoui_: Yes
14:54 nefzaoui_: in Arabic I think
14:54 nefzaoui_: We should start with Arabic
14:54 nefzaoui_: then English
14:55 gandalf: so, sorted arabic letters, then sorted english?
14:55 nefzaoui_: That was in the spec steph made too
14:55 nefzaoui_: yes
14:55 nefzaoui_: and I agree with her on that
14:55 iiddnn has joined (iacopodeeno@moz-m23dv9.retail.telecomitalia.it)
14:55 whsu has joined (William@moz-714.34n.254.122.IP)
14:55 nefzaoui_: Sorted Arabic followed by sorted English songs
14:55 gandalf: how would groupings (a...c, d...f etc.) look like? arabic character groups and then english groups?
14:55 squib: i wonder if the collator actually does it that way...
14:56 pdahiya has left IRC (Ping timeout: 121 seconds)
14:56 nefzaoui_: Yeah grouping Arabic titles like (أ.. ب.. ت..) and then (a..b..)
14:57 pdahiya has joined (chatzilla@moz-b5ss57.ca.comcast.net)
14:57 nefzaoui_: yes Arabic characters grouped altogether
14:57 nefzaoui_: and then English ones
14:57 anaran has left IRC (Client exited)
14:57 anaran has joined (Thunderbird@moz-483um8.dynamic.qsc.de)
14:57 nefzaoui_: that is what Stephany Wilkes suggested for 2.2, and as I don't have any alternative, I can't help but agree it's the best we could do
14:57 gandalf: mhm
14:58 gandalf: ok, great to know!
14:58 CMDann has left IRC (Ping timeout: 121 seconds)
14:58 nefzaoui_: even though I'm not sure how possible is that technically (without too much hassle)
14:59 gandalf: justindarc, squib: so it's possible that ultimately we want to have list of alphabets (latin, eastern-arabic, etc.) and then group titles into those alphabets and then sort them within alphabets
14:59 gandalf: and then put the alphabet of the current locale first
14:59 squib: hm, ok
14:59 gandalf: that does not answer accented latin, but may help you plan for non-latin
14:59 justindarc: gandalf: since we're vertically limited for space..
14:59 iiddnn has left ()
15:00 justindarc: i'm going to suggest that we hold off on the A-Z picker until this scenario is accounted for
15:00 gandalf: yeah, I agree
15:00 justindarc: ideally, we can switch alphabets in the A-Z picker, like you would a keyboard
15:00 gandalf: all I'm saying is that you may want to think of it while designing your DB model and interactions
15:00 gigitux has left IRC (Ping timeout: 121 seconds)
15:00 justindarc: gandalf: yes.. and we're already using Intl to sort by locale, so that's good.. future DB design will likely store pre-sorted indexes per locale
15:01 avikpal has left IRC (Connection closed)
15:01 justindarc: squib: hub: remove A-Z picker for v2.5?
15:01 squib: justindarc: let's kill it

According to :nefzaoui_, we had a spec for v2.2 that called for grouping music by the locale-specific alphabet first, followed by the English alphabet. Currently, the <gaia-fast-list> A-Z picker is English-only and will not work properly with the current locale-specific sorting. In order for this to work, the A-Z picker will need a way to toggle between the current locale's alphabet and the English alphabet.
(Assignee)

Comment 1

3 years ago
Flagging :robmac for NI? to get this on UX's radar and so it gets routed to the appropriate designer since the A-Z picker spans multiple apps.
Flags: needinfo?(rmacdonald)
don't forget to reopen the original bug.
I'll be happy to help designing the Intl API part of the future character grouping for lists
Created attachment 8672063 [details] [review]
[gaia] justindarc:bug1213381 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Assignee: nobody → jdarcangelo
(Assignee)

Updated

3 years ago
Attachment #8672063 - Flags: review?(squibblyflabbetydoo)
Currently Android and iOS hide the picker for non-roman locales. I suggest we do the same at least in the short term. I guess we'd need a list of locale ids to either hide or show by. Gandal, what do you suggest?
Flags: needinfo?(gandalf)
(Assignee)

Comment 6

3 years ago
(In reply to Wilson Page [:wilsonpage] from comment #5)
> Currently Android and iOS hide the picker for non-roman locales. I suggest
> we do the same at least in the short term. I guess we'd need a list of
> locale ids to either hide or show by. Gandal, what do you suggest?

In addition to the l10n issues, we also had issues on how to deal with the transition between the regular view and "search" mode. This was another motivation for removing the picker in the short term.
(In reply to Wilson Page [:wilsonpage] from comment #5)
> Currently Android and iOS hide the picker for non-roman locales. I suggest
> we do the same at least in the short term. I guess we'd need a list of
> locale ids to either hide or show by. Gandal, what do you suggest?

I believe that it's a good path forward. I understand the motivation Justin has to remove it now, and I believe it would be valuable to bring it back as soon as possible for latin locales before we figure out how to show it for non-latin.
Flags: needinfo?(gandalf)
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #7)
> (In reply to Wilson Page [:wilsonpage] from comment #5)
> > Currently Android and iOS hide the picker for non-roman locales. I suggest
> > we do the same at least in the short term. I guess we'd need a list of
> > locale ids to either hide or show by. Gandal, what do you suggest?
> 
> I believe that it's a good path forward. I understand the motivation Justin
> has to remove it now, and I believe it would be valuable to bring it back as
> soon as possible for latin locales before we figure out how to show it for
> non-latin.

Can you provide us with (or suggest where we would find) a list of locale ids that we should show the picker for?
Flags: needinfo?(gandalf)
(Assignee)

Comment 9

3 years ago
(In reply to Wilson Page [:wilsonpage] from comment #8)
> (In reply to Zibi Braniecki [:gandalf][:zibi] from comment #7)
> > (In reply to Wilson Page [:wilsonpage] from comment #5)
> > > Currently Android and iOS hide the picker for non-roman locales. I suggest
> > > we do the same at least in the short term. I guess we'd need a list of
> > > locale ids to either hide or show by. Gandal, what do you suggest?
> > 
> > I believe that it's a good path forward. I understand the motivation Justin
> > has to remove it now, and I believe it would be valuable to bring it back as
> > soon as possible for latin locales before we figure out how to show it for
> > non-latin.
> 
> Can you provide us with (or suggest where we would find) a list of locale
> ids that we should show the picker for?

A few other things to keep in mind if we're going to whitelist a subset of locales:
* Whitelisted locales must also sort in the same order that A-Z appears in the picker
* Because of the locale-based sorting, the "#" grouping must appear *before* "A" in the picker
* We would also need to pre-process each string of sorted text to strip all accented characters
  - https://github.com/tc39/ecma402/issues/44
  - Possible polyfill for the above which may be computationally expensive: https://gist.github.com/yeah/1283961

After considering the above, I'm still not 100% convinced that we should rush into enabling this without some additional thought.
I'm not suggesting rush. I totally understand you may want to remove it in 2.5. But I think it's a feature worth bringing back soon after, and I don't think we can provide a valudable back-end for multi-script A-Z picker, so I agree with Wilson that we should start with latin script based ones.

> Can you provide us with (or suggest where we would find) a list of locale ids that we should show the picker for?

I'll look into this.

Comment 11

3 years ago
Comment on attachment 8672063 [details] [review]
[gaia] justindarc:bug1213381 > mozilla-b2g:master

Looks good to me, although I was a bit confused by one part. See the comments on GitHub.
Attachment #8672063 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 12

3 years ago
(In reply to Jim Porter (:squib) from comment #11)
> Comment on attachment 8672063 [details] [review]
> [gaia] justindarc:bug1213381 > mozilla-b2g:master
> 
> Looks good to me, although I was a bit confused by one part. See the
> comments on GitHub.

I replied to your comments on GitHub. We were not correctly falling back to the localized "unknown" strings for the sub-titles in the list items.

Landed on master:

https://github.com/mozilla-b2g/gaia/commit/470ecf899417957f414507b73213a816006ff5da
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1213387
Flags: needinfo?(gandalf)
(Assignee)

Updated

2 years ago
Flags: needinfo?(rmacdonald)
You need to log in before you can comment on or make changes to this bug.