The default bug view has changed. See this FAQ.

Firefox needs multiple e10s content processes to isolate badly performing tabs (process-per-tab)

RESOLVED DUPLICATE of bug 1207306

Status

()

Core
DOM: Content Processes
RESOLVED DUPLICATE of bug 1207306
2 years ago
9 months ago

People

(Reporter: vladan, Unassigned)

Tracking

(Blocks: 2 bugs)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10slater)

Details

(Whiteboard: [content perf])

(Reporter)

Description

2 years ago
A tab’s performance should not depend on the behavior of other unrelated tabs. We need process-per-tab E10S to isolate tabs' performance from each other.

Obviously the solution is not as simple as spawning a process for each tab. There needs to be a limit to the number of content-processes, there need to be rules for sharing content processes among tabs when the limit is reached, and the memory overhead of each content-process needs to be trimmed.

As an example of the potential impact of background tab activity, we measured the impact of loading GMail in a background tab while scrolling a page in a foreground tab. 

Our results: https://docs.google.com/spreadsheets/d/13SgzLq6IWj38LvhPnU7YE07F0XsZaYSNyPBBMZch5_M/edit#gid=0

* In the tests above, the foreground tab was alternately Yahoo search results, a Twitter user page, and a Facebook profile
* The test laptop was a reference content-perf laptop: HP 14t i3-5010u in the stock “HP Recommended” (balanced) power profile, plugged into power
(Reporter)

Updated

2 years ago
Blocks: 1213469

Updated

2 years ago
tracking-e10s: --- → later

Updated

a year ago
Blocks: 1207306

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207306
You need to log in before you can comment on or make changes to this bug.