Recover from malformed URLs by ignoring the protocol field

RESOLVED DUPLICATE of bug 22251

Status

()

Core
Networking: HTTP
--
enhancement
RESOLVED DUPLICATE of bug 22251
16 years ago
16 years ago

People

(Reporter: zwol, Assigned: Darin Fisher)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If you load the page at the referenced URL you will see a number of A tags
of the form

   <a href="http:file.html">link</a>

The author meant this to mean the same as

   <a href="file.html">link</a>

but Mozilla interprets it as

   <a href="http://file.html/">link</a>

i.e. it attempts to contact a host named file.html by HTTP.  Of course it
cannot find any DNS entry for that host, so you get an error dialog box.

It would be nice if, in this situation, Mozilla responded to the failure of
DNS lookup by reinterpreting the URL as if it hadn't had a protocol field
in the first place.  This would cause the page to work as the author intended.
See bug 32966 and bug 22251.  This has all already been beaten to death...

Marking as duplicate of bug 22251, since that one fits this bug more closely.

*** This bug has been marked as a duplicate of 22251 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.