No sound in videos from France 24

RESOLVED DUPLICATE of bug 1214148

Status

P3
normal
RESOLVED DUPLICATE of bug 1214148
3 years ago
3 years ago

People

(Reporter: gerard-majax, Assigned: alwu)

Tracking

({foxfood, regression})

unspecified
foxfood, regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [bzlite])

Attachments

(3 attachments, 6 obsolete attachments)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Playing videos from France 24 app available on marketplace there is no sound. All channels are at the proper level. There is sound in videos from YouTube.

This used to work as far as I can tell at least a couple of weeks ago.
(Reporter)

Comment 1

3 years ago
Created attachment 8672376 [details]
system-b2g-application.ini
(Reporter)

Comment 2

3 years ago
Created attachment 8672377 [details]
dev-log-main.log
(Reporter)

Comment 3

3 years ago
Created attachment 8672378 [details]
properties.log
(Reporter)

Comment 4

3 years ago
Created attachment 8672379 [details]
screenshot.png
[Blocking Requested - why for this release]:

Nominating for 2.5 release. 

QAnalysts, Can you please help finding clear STR for this issue and if its with any audio playing etc..

Thanks
blocking-b2g: --- → 2.5?
Keywords: qawanted
The bug can be repro on latest build of Flame KK v2.5 & Aries KK v2.5 by the following STR, but it can't be repro on latest build of Flame KK v2.2.

STR:
precondition: Have a France 24 app installed from marketplace in the homescreen.
1. Lanuch France 24 app in the homescreen.
2. Select a video to play.

Actual Result: After the video plays about several seconds with no sound, the animation will stay static, even if you drag the progress slider or tap play/pause for several times. 
Reproduce rate: 10/10
See attachment: Aries_v2.5.3gp and logcat_1522.txt.

Device:Flame KK v2.5(Affected)
Build ID               20151019150205
Gaia Revision          a87f947366c2e044bd6336e1982419ac45378969
Gaia Date              2015-10-19 15:22:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9605da94e75d61598d3c00f01a12d1b6bc427a6c
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151019.182947
Firmware Date          Mon Oct 19 18:29:58 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device:Aries KK v2.5(Affected)
Build ID               20151019205841
Gaia Revision          a87f947366c2e044bd6336e1982419ac45378969
Gaia Date              2015-10-19 15:22:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9605da94e75d61598d3c00f01a12d1b6bc427a6c
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151019.201730
Firmware Date          Mon Oct 19 20:17:38 UTC 2015
Bootloader             s1

Device:Flame KK v2.2(Unaffected)
Build ID               20151019032501
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6b4e563acaf9
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151019.070114
Firmware Date          Mon Oct 19 07:01:25 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Keywords: qawanted
Keywords: regression, regressionwindow-wanted
Component: Gaia::Feedback → AudioChannel
QA Contact: sleedavid
(Reporter)

Comment 9

3 years ago
I don't reproduce that anymore ... ?
(Reporter)

Comment 10

3 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #9)
> I don't reproduce that anymore ... ?

I remember the bug was occuring when playing the videos within the app. Today, I'm back fighting with that bug that makes me unable to start videos from within the France 24 app and I have to long press, open in a new window, and there it works.
(Reporter)

Comment 11

3 years ago
Right, loading within the app is currently blocked by tracking protection as documented on bug 1174532 comment 32. Once disabled, I can play videos within the app and I have no sound. Opening the same video in Browser, I have sound.
QA Contact: sleedavid
Blocks 2.5 with a P3 priority.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P3
QA Contact: jmercado
A regression window cannot be found for this issue.  There are builds for about a month between 7-17 and 8-17 where the video will not play at all when clicked on.  This issue does not occur before this and does occur after.

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150717071605
Gaia: 8c009877aff6b8b2f4a60756e2d09c0182393721
Gecko: 6ef209dd237f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150817055138
Gaia: 60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gecko: 028fa40d0ab80b2224b0f9d3eb8daab052f700bd
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

3 years ago
Assignee: nobody → alwu
(Assignee)

Comment 14

3 years ago
Created attachment 8681053 [details]
Log : Successful / Fail case comparision

From the log, we can see the app doesn't get the "audio focus" from the system app, so it can't be playback.

---

Hi, Evan,
Could you help me check this issue?
Thanks!
Flags: needinfo?(evan)
(Assignee)

Updated

3 years ago
Assignee: alwu → nobody
Component: AudioChannel → Gaia::System::Audio Mgmt
Hi Alastor,

After investigated, the root cause it that gaia just cannot receive the `activestatechanged` event from gecko when the normal audio channel belonged to "France 24" want to play sounds.

Looks like it is a gecko bug.
Component: Gaia::System::Audio Mgmt → AudioChannel
Flags: needinfo?(evan)
Looks like a 3rd-party app can play audio, but it cannot play video. For example, SoundCloud can play a mp3 music, but France 24 cannot play a video wit sounds.

So is there something wrong with handling a video in gecko?
(Assignee)

Updated

3 years ago
Assignee: nobody → alwu
(Assignee)

Comment 17

3 years ago
Created attachment 8681184 [details]
Log : wrong window ID

After register the AudioChannelAgent, we'll send the event to notify the system app. However, this event can't send correctly. It would be stopped in the TabChild because of the wrong window ID.

---

Hi, Baku,
Could you help me check this situation?
It seems the we are in the special DOM window case, we would send the event to the wrong TabChild.
Thanks!
Flags: needinfo?(amarchesini)
(Reporter)

Comment 18

3 years ago
I have also notices that pauseing the video I cannot resume playback when in the France 24 app. When I open the same video in browser it's working as expected.
(Assignee)

Comment 19

3 years ago
Created attachment 8682405 [details]
Log : window ID (scriptable parent v.s. real parent)

From the log, it seems that it's also the nested mozBrowser frame case.

The owner of the MediaElement is another mozBrowser frame, so we can't send the event out to the system app.
Attachment #8672376 - Attachment is obsolete: true
Attachment #8672377 - Attachment is obsolete: true
Attachment #8672378 - Attachment is obsolete: true
Attachment #8676082 - Attachment is obsolete: true
Attachment #8681053 - Attachment is obsolete: true
Attachment #8681184 - Attachment is obsolete: true
(Assignee)

Comment 20

3 years ago
According to comment19, it's the same root cause.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1214148
Flags: needinfo?(amarchesini)
You need to log in before you can comment on or make changes to this bug.