Closed Bug 1213700 Opened 4 years ago Closed 4 years ago

When creating a livemark, wrong item gets edited

Categories

(SeaMonkey :: Bookmarks & History, defect)

defect
Not set

Tracking

(seamonkey2.40 fixed, seamonkey2.41 fixed)

RESOLVED FIXED
seamonkey2.41
Tracking Status
seamonkey2.40 --- fixed
seamonkey2.41 --- fixed

People

(Reporter: neil, Assigned: neil)

Details

Attachments

(1 file)

Steps to reproduce problem:
1. View a feed
2. Try to subscribe using Live Bookmarks

Expected result: Dialog allows you to rename the new live bookmark

Actual result: Dialog edits unrelated bookmark
Attached patch Possible patchSplinter Review
Creating livemarks is now asynchronous, sigh, so we have to wait for it to complete before filling in the dialog, which is ugly, but there you go.
Attachment #8672417 - Flags: review?(iann_bugzilla)
Summary: When editing a livemark, wrong item gets edited → When creating a livemark, wrong item gets edited
Comment on attachment 8672417 [details] [diff] [review]
Possible patch

The equivalent Firefox code makes use of yield, is this something we should be doing?
Flags: needinfo?(neil)
Attachment #8672417 - Flags: review?(iann_bugzilla) → review+
Assignee: nobody → neil
Status: NEW → ASSIGNED
When you start doing that you have to start messing around with Tasks too and I thought that was overkill.
Flags: needinfo?(neil)
Pushed comm-central changeset 80d9a14e1c43.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.41
Comment on attachment 8672417 [details] [diff] [review]
Possible patch

[Approval Request Comment]
Regression caused by (bug #): 1094900
String changes made by this patch: None
Attachment #8672417 - Flags: approval-comm-aurora?
Attachment #8672417 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.