Clicking on textareas in box model collapses them instead of canceling text selection

RESOLVED FIXED in Firefox 46

Status

RESOLVED FIXED
4 years ago
9 months ago

People

(Reporter: arni2033, Assigned: jdescottes)

Tracking

Trunk
Firefox 46

Firefox Tracking Flags

(firefox41 affected, firefox42 affected, firefox43 affected, firefox44 affected, firefox46 fixed, firefox47 fixed, firefox-esr38 affected)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

4 years ago
STR:   (Win7_64, Nightly 44, 32bit, ID 20151012030612, new profile)
1. Open devtools > Inspector on this page, select <body> in markup-view, open "Box Model" tab in sidebar
2. Click margin-left value   [textarea with the value will open]
3. Click the textarea

Result:       Textarea is collapsed

Expectations: Text selection in textarea should be canceled. Example of this behavior: in ruleview,
              textarea with selected text appears when I click rule's name/value.
              When I click the selected text in textarea, the selection is being canceled.
(Reporter)

Updated

3 years ago
Has STR: --- → yes
(Assignee)

Comment 1

3 years ago
Posted patch bug1214177.v1.patch (obsolete) — Splinter Review
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Attachment #8709741 - Flags: review?(pbrosset)
Comment on attachment 8709741 [details] [diff] [review]
bug1214177.v1.patch

Review of attachment 8709741 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thanks.
Attachment #8709741 - Flags: review?(pbrosset) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 5

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4a4e84b327cb
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
(Reporter)

Comment 6

3 years ago
Verified fixed on   [Win7_64, Nightly 46, 32bit, ID 20160126030244]

However, is that completely OK that I now can't collapse textarea by clicking outside of it?
Status: RESOLVED → VERIFIED
(Assignee)

Comment 7

3 years ago
(In reply to arni2033 from comment #6)
> Verified fixed on   [Win7_64, Nightly 46, 32bit, ID 20160126030244]
> 
> However, is that completely OK that I now can't collapse textarea by
> clicking outside of it?

I can't reproduce this on Nightly OSX. If I click outside of a textarea, it turns back to a non-editable field. (see attached gif)

Am I missing a step here ?
Flags: needinfo?(arni2033)
(Assignee)

Comment 8

3 years ago
Ok, I just updated nightly and I have the same issue now. Investigating.
Flags: needinfo?(arni2033)
(Assignee)

Comment 9

3 years ago
Looks like the issue mentioned by arni2033 started with commit 8710bfc4121a (https://hg.mozilla.org/mozilla-central/rev/8710bfc4121a).

In the "Box model" tab of the inspector, when you edit a margin/padding/border value, the input field is no longer blurred when clicking outside of it. Gabriel, any idea why?
Flags: needinfo?(gl)
(Assignee)

Comment 10

3 years ago
Understood why this no longer works : the tabpanel "sidebar-panel-layoutview" including the HTML for the layout tab has "-moz-user-focus:ignore" => all elements other than inputs can no longer receive focus and therefore no longer trigger a blur event.
(Assignee)

Comment 11

3 years ago
Posted patch bug1214177.part2.v1.patch (obsolete) — Splinter Review
Attachment #8709741 - Attachment is obsolete: true
Attachment #8712961 - Flags: review?(gl)
(Assignee)

Comment 12

3 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=46de3449d999

Bug 1214177 - Allow focus inside HTML docs of inspector.xul

After Bug 1238133, HTML documents are directly loaded inside XUL elements.

They inherit a -moz-user-focus: ignore; coming from minimal-xul.css.
Usually this is overridden by xul.css, which restores -moz-user-focus: normal;
on iframe, browser and some other elements.

This commit adds a new class to all inspector tab panel elements including html,
and a new CSS rule to override the default -moz-user-focus.

Also added a new test case dedicated to this.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

3 years ago
Blocks: 1241126
Attachment #8712961 - Flags: review?(gl) → review+
Flags: needinfo?(gl)
(Assignee)

Comment 13

3 years ago
Thanks for the review, just rebased.

Carry over r+
Attachment #8712961 - Attachment is obsolete: true
Attachment #8714255 - Flags: review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 15

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5a4ae5f44774
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
I have reproduced this bug according to (2015-10-13)

It's fixed on Latest Nightly & Developer Edition

Nightly -- Build ID (20160326030430), User Agent : Mozilla/5.0 (Windows NT 6.3; rv:48.0) Gecko/20100101 Firefox/48.0

Developer Edition -- Build ID (20160326004034), User Agent : Mozilla/5.0 (Windows NT 6.3; rv:47.0) Gecko/20100101 Firefox/47.0

Tested OS-- Windows8.1 32bit
QA Whiteboard: [testday-20160401]

Comment 17

3 years ago
unhelpful
[bugday-20160323]

Status: RESOLVED,FIXED -> VERIFIED

Comments:
test successful.

Component: 
Name 			Firefox
Version 		46.0b9
Build ID 		20160322075646
Update Channel 	        beta
User Agent 		Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
OS                      Windows 7 SP1 x86_64

Expected Results: 
Size changes accordingly textarea modifies. If left padding changes, browser UI shifts accordingly.

Actual Results: 
As expected
I've managed to reproduce this bug on Nightly 44.0a1 (2015-10-13) (Build ID: 20151013030225 ) on Linux, 64 Bit.

This Bug is now verified as fixed on Latest Firefox Nightly 50.0a1 (2016-06-29)

Build ID: 20160629030209
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
OS: Ubuntu 14.04 ; inux 3.19.0-61-generic
QA Whiteboard: [testday-20160401] → [testday-20160401][bugday-20160629]

Updated

9 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.