[e10s] Add-on installation fails when the current tab is non-remote

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: mboldan, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 affected, firefox44 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8673102 [details]
wrong notification.png

Reproducible with 44.0a1 (20151011030229), 43.0a2 (20151012004021)
Affected platforms: Windows 10 x86, Ubuntu 14.04 x86 and Mac OS X 10.10.4

Steps to reproduce:
1. Launch Firefox and open a new tab using about:newtab.
2. Using File->Open file, open an unverified Add-on.

Expected results:
The 'This add-on could not be installed because it has not been verified.' notification is displayed.

Actual results: 
The 'Downloading and verifying' pop up is displayed blocked on Verifying with the progress bar completed 100% (see the attached screenshot).

Notes:
This issue is not reproducible with the e10s disabled or if trying to install signed or corrupted add-ons.
This issue is reproducible only when using about:newtab and if the file is opened from File->Open file.
The issue is a regression as it's not reproducible on Firefox 42.0a1 (20150703030216).
I will follow up with the regression range as soon as possible.
This is extremely similar to bug 1204215 just with slightly different results. It is mostly caused by the effects of bug 1175267 though bug 1042699 likely shows up as the regressor.
Blocks: 1042699, 1175267
Summary: [e10s] A wrong notification is displayed if trying to install an unsigned add-on in about:newtab → [e10s] Add-on installation fails when the current tab is non-remote
This issue is no longer reproducible on Firefox 51.0a1 (2016-08-29), Firefox 50.0a2 (2016-08-29), Firefox 49.0b7 (20160825132718) under Windows 10 64-bit. 'This add-on could not be installed because it has not been verified.' message is successfully displayed when installing unverified add-ons.  

Marking this bug as WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.