Closed Bug 1214259 Opened 4 years ago Closed 4 years ago

[e10s] <options>s style="display: none;" does not work

Categories

(Core :: Layout: Form Controls, defect)

43 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
e10s m8+ ---
firefox44 --- fixed

People

(Reporter: rdrgwtrs, Assigned: gw280)

References

()

Details

(Whiteboard: [dupe me])

Attachments

(2 files, 1 obsolete file)

Attached image IMG_0103.jpg
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151013004018

Steps to reproduce:

<select> 
  <option value="1" >Volvo</option> 
  <option value="3" style="display:none;">Mercedes</option> 
  <option value="4">Audi</option> 
</select> 


Actual results:

Mercedes is visible


Expected results:

Mercedes is not visible
Summary: style="display: none;" does not work → <options>s style="display: none;" does not work
I can reproduce the problem with e10s, but not without e10s.
Status: UNCONFIRMED → NEW
tracking-e10s: --- → ?
Component: Untriaged → Layout: Form Controls
Ever confirmed: true
Product: Firefox → Core
Summary: <options>s style="display: none;" does not work → [e10s] <options>s style="display: none;" does not work
maybe dup of Bug 910022
Whiteboard: [dupe me]
Assignee: nobody → gwright
Wouldn't this cause the selection to be incorrect when selecting those items after the hidden one?
Yeah, you're right. I'll prepare a new patch.
Attachment #8674396 - Attachment is obsolete: true
Attachment #8674396 - Flags: review?(enndeakin)
Attachment #8675695 - Flags: review?(enndeakin)
Attachment #8675695 - Flags: review?(enndeakin) → review+
https://hg.mozilla.org/mozilla-central/rev/2ebedb306b62
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
You need to log in before you can comment on or make changes to this bug.