Closed Bug 1214342 Opened 4 years ago Closed 4 years ago

"Incoming" and "Connecting" text on Callscreen will briefly display very large on screen when the call is connected.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: Marty, Assigned: gsvelto)

References

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(4 files)

Description:
Right when the call is accepted, the "Incoming" (for inbound calls) or "Connecting" (for outbound calls) text will display very large before the text is replaced with the call duration timer.

Note: This issue is more dramatic on Flame, with the lower screen resolution compared to Aries.

Repro Steps:
1) Update a Aries to 20151013110851
2) Open the dialer app.
3) Make a call to another device.
4) Observe the 'Connecting' text as the recipient answers the call.

Actual:
The text briefly becomes very large when the call is accepted.

Expected:
The text does not change size when the call is accepted.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151013110851
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 8/8
See attached: Screenshot, Logcat
This issue DOES occur on the latest Flame 2.5 build.
The text briefly becomes very large when the call is accepted.

Environmental Variables:
Device: Flame 2.5
BuildID: 20151013030230
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

*********************************

This issue does NOT occur on the latest Flame 2.2 build.
The text does not change size when the call is accepted.

Environmental Variables:
Device: Flame 2.2
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Minor but let's get a regression window to see what caused this to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This could be a consequence of bug 1212151, it might be worth checking it out.
QA Contact: jthomas
This issue is caused by changes made in Bug 1212151

B2g Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20151012071910
Gaia: 8b79556de1e0d602650b985a2b0af9c86b528c05
Gecko: b3df0fc12543f5b4a8ed6297bf5c4884cecdf2b9
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20151012085911
Gaia: 87a208aa1d136f3adebec82330f2156eee2bfca8
Gecko: a89ac66333b613effea9773eaa2ba12d8eb942a4
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working gaia / First Broken gecko - This issue does NOT occur with broken Gecko
Gaia: 8b79556de1e0d602650b985a2b0af9c86b528c05
Gecko: a89ac66333b613effea9773eaa2ba12d8eb942a4

Last Working gecko / First Broken gaia - This issue DOES occur with broken Gaia
Gecko: b3df0fc12543f5b4a8ed6297bf5c4884cecdf2b9
Gaia: 87a208aa1d136f3adebec82330f2156eee2bfca8

B2g Inbound Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/8b79556de1e0d602650b985a2b0af9c86b528c05...87a208aa1d136f3adebec82330f2156eee2bfca8
Blocks: 1212151
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Taking! Sorry for that regression.
Assignee: nobody → gandalf
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Ok, so it's another l10n id collision problem caused by this:

https://github.com/mozilla-b2g/gaia/blob/master/apps/callscreen/js/handled_call.js#L79-L80

It's overall an interesting line of code - while my patch did update the "incoming" (and potentially made this bug more visible), I did not touch the "connecting" entity, which is still in dialer.en-US.properties and has a value, so it should be displayed.

If I understand correctly, before my patch, the "Connecting" string would show, but the "Incoming" would not.

Now, both, 'incoming' and 'connecting' strings are in dialer and have value which is then (I guess) overridden in 'updateDirection' - https://github.com/mozilla-b2g/gaia/blob/master/apps/callscreen/js/handled_call.js#L361-L367

Gabriele - how do you want me to fix this bug?
Flags: needinfo?(gsvelto)
The issue here is a bit subtler than I thought. We do want to show the 'incoming' entity until the call is connected but there's no 'connecting' state anymore (it's been removed in gecko) so that part should go away. We should also never resize the element as long as we're in the 'incoming' state which is what we're seeing here.
Assignee: gandalf → gsvelto
Status: NEW → ASSIGNED
Flags: needinfo?(gsvelto)
Comment on attachment 8675175 [details] [review]
[gaia] gabrielesvelto:bug-1214342-callscreen-connecting-incoming-l10n-fix > mozilla-b2g:master

Further investigation turned out that the bug was a lot simpler than I thought: we were setting the textContent field of the node which contained the 'connecting'/'incoming' entities without first removing the data-l10n-id attribute. This patch fixes the issue by always removing the data-l10n-id attribute when creating the ticker.
Attachment #8675175 - Flags: review?(drs)
Attachment #8675175 - Flags: review?(drs) → review+
Merged to gaia/master bc3fcffdda9e2c11ed8b7675c146fedbb6a95c11

https://github.com/mozilla-b2g/gaia/commit/bc3fcffdda9e2c11ed8b7675c146fedbb6a95c11
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This bug has been verified as pass on latest build of Flame KK v2.5 and Aries KK v2.5 by the STR in comment 0.
Actual results: The 'Incoming' and 'Connecting' texts, which are displayed transitorily while the call is connected,have been removed.
See attachment: Verified_Aries_v2.5.3gp.
Reproduce rate: 0/10.

Device: Flame KK v2.5 (Pass)
Build ID               20151025150204
Gaia Revision          1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gaia Date              2015-10-23 17:01:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d53a52b39a95dced722cca90ac74529b66dd5253
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151025.201952
Firmware Date          Sun Oct 25 20:20:05 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Pass)
Build ID               20151025085903
Gaia Revision          1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gaia Date              2015-10-23 17:01:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d53a52b39a95dced722cca90ac74529b66dd5253
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151025.081846
Firmware Date          Sun Oct 25 08:18:54 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.