Multiple app have rocket ship icon in card view/task manager

VERIFIED FIXED

Status

Firefox OS
Gaia::System::Task Manager
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: AdamA, Assigned: mcav)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe])

Attachments

(7 attachments)

(Reporter)

Description

2 years ago
Created attachment 8673381 [details]
logcat

Description:
there are multiple apps that have a blank rocket ship icon in card view. Notes, Foxfooding, calculator, and swooop all have blank rocket icons.

Repro Steps:
1) Update a Aries to 20151013110851
2) Open Notes, Foxfooding, calculator, or swooop
3) Long press the home button
4) Observe icons at bottom of cards

Actual:
multiple apps have rocket icons in card view

Expected:
It is expected that the icons in card view are the same as the app icons

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20151013110851
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
See attached: Screenshots, logcat
(Reporter)

Comment 1

2 years ago
Created attachment 8673382 [details]
Calculator icon
(Reporter)

Comment 2

2 years ago
Created attachment 8673384 [details]
Foxfooding icon
(Reporter)

Comment 3

2 years ago
Created attachment 8673385 [details]
Swooop icon
(Reporter)

Comment 4

2 years ago
Created attachment 8673386 [details]
Notes icon
(Reporter)

Comment 5

2 years ago
Notes app was used because it is available in marketplace.
--------------------------------
This issue DOES occur Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20151013030230
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
Notes app have rocket icon in card view
------------------------------------
This issue DOES NOT occur in Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
notes app has same icon as app icon on homescreen in card view.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
(Assignee)

Updated

2 years ago
Assignee: nobody → m
(Assignee)

Comment 7

2 years ago
Surprisingly, this is *not* a regression from the task manager refactor. Investigating.
(Assignee)

Updated

2 years ago
See Also: → bug 1211662

Comment 8

2 years ago
Created attachment 8673733 [details] [review]
[gaia] mcav:tm-icon > mozilla-b2g:master
(Assignee)

Comment 9

2 years ago
Comment on attachment 8673733 [details] [review]
[gaia] mcav:tm-icon > mozilla-b2g:master

Alberto, is this what you had in mind? It fixes this bug, but it feels a little messy (with siteObj's semantics being somewhat unclear).

(If this is the right approach, I'll add a test.)
Attachment #8673733 - Flags: feedback?(apastor)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Comment on attachment 8673733 [details] [review]
[gaia] mcav:tm-icon > mozilla-b2g:master

Yeah, that's it. The whole siteObj thingy is a little bit messy right now, so let's fix this blocker for now and refactor it afterwards. Thanks!
Attachment #8673733 - Flags: feedback?(apastor) → feedback+
Duplicate of this bug: 1211662
blocking-b2g: 2.5? → ---
(Assignee)

Updated

2 years ago
Attachment #8673733 - Flags: review?(apastor)
Comment on attachment 8673733 [details] [review]
[gaia] mcav:tm-icon > mozilla-b2g:master

LGTM. Thanks!
Attachment #8673733 - Flags: review?(apastor) → review+
master: https://github.com/mozilla-b2g/gaia/commit/a9c86a906a2dcda363df542521d497539a83dfdd
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 14

2 years ago
The line at https://github.com/mozilla-b2g/gaia/blame/master/apps/system/js/app_window.js#L2524 is buggy.

It should be |siteObj.origin = new URL(this.origin).origin;|

Otherwise you end up miscalculating the icon url for the communication app (or apps that may have a #something) in their launch path.
(Assignee)

Comment 15

2 years ago
Thanks, Vivien; that has been fixed in bug 1215550.
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: The icons of these apps in card view are shown normally and corresponding to the app icon instead of rocket icon.
See attachment: verified_Aries_v2.5.png
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20151019150205
Gaia Revision          a87f947366c2e044bd6336e1982419ac45378969
Gaia Date              2015-10-19 15:22:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9605da94e75d61598d3c00f01a12d1b6bc427a6c
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151019.182947
Firmware Date          Mon Oct 19 18:29:58 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151019205841
Gaia Revision          a87f947366c2e044bd6336e1982419ac45378969
Gaia Date              2015-10-19 15:22:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9605da94e75d61598d3c00f01a12d1b6bc427a6c
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151019.201730
Firmware Date          Mon Oct 19 20:17:38 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: affected → verified
Created attachment 8676060 [details]
verified_Aries_v2.5.png
You need to log in before you can comment on or make changes to this bug.