[RFE] add "mark link as unvisited" to link context menu (remove from global history)

RESOLVED DUPLICATE of bug 75338

Status

()

Core
History: Global
--
enhancement
RESOLVED DUPLICATE of bug 75338
16 years ago
5 years ago

People

(Reporter: Matt Kraai, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Sometimes I visit a link, and then move on before reading it.  Since it is
marked as visited, I don't know to return to it later.  If I right-click on a
link, it would help to have a menu item which would remove the link from the
history.  That way, I would know that I hadn't read that link after all.

Updated

16 years ago
Summary: add menu item to remove link from global history → add "mark link as unvisited" to browser context menu (remove from global history)

Comment 1

16 years ago
There is such a menu item.  It's called Delete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

16 years ago
On which menu?  When I right-click on a link, I don't see a Delete item in the
resulting menu.  This is with Build ID 2002021708.

Comment 3

16 years ago
Open up the History window or sidebar, right-click on a link, select delete.
(Reporter)

Comment 4

16 years ago
This sucks.  In order to unvisit a link, I have to open the Sidebar, select the
History pane, open Today, open the site I want to remove the link from, right
click on the page to unvisit, and choose Delete.

If it was on the browser context menu, I could right-click on the link and
select "Mark link as unvisited".

Comment 5

16 years ago
Reopening.  Let's see what the History people have to say.

From an email from the reporter:
Perhaps a button to this effect could be added to the Link
Properties frame of the Element Properties dialog?  It wouldn't be
as convenient, but it would be better than the current situation.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: add "mark link as unvisited" to browser context menu (remove from global history) → [RFE] add "mark link as unvisited" to link context menu (remove from global history)

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 75338 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 7

5 years ago
Sorry to reopen, but I do not see this functionality in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18? I would love to be able to click a link as followed or unfollowed without having to open a page. Drive's me nuts.
You need to log in before you can comment on or make changes to this bug.