[FxOS] Browser crashes when enabling network during loading video

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: bwu, Assigned: ayang)

Tracking

({crash})

37 Branch
ARM
Gonk (Firefox OS)
crash
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Reporter)

Description

3 years ago
This bug is aimed to fix the crash found in Bug 1189143 comment 17 and 18.
(Reporter)

Updated

3 years ago
Summary: [FxOS] Browser cashes when enabling network during loading video → [FxOS] Browser crashes when enabling network during loading video

Comment 1

3 years ago
Blake, please help for investigation. thanks.
blocking-b2g: --- → 2.5+
Flags: needinfo?(bwu)
Keywords: crash
Priority: -- → P1
See Also: → bug 1189143
(Reporter)

Comment 2

3 years ago
Alfredo, 
Are you available to help check this bug?
Flags: needinfo?(bwu) → needinfo?(ayang)

Updated

3 years ago
Blocks: 1214243
(Assignee)

Comment 3

3 years ago
(In reply to Blake Wu [:bwu][:blakewu] from comment #0)
> This bug is aimed to fix the crash found in Bug 1189143 comment 17 and 18.

I think comment 17 and comment 18 are different problems.
Comment 18 is solved in bug 1210045.
Comment 17 is more likely the same one bug in 1189143.

So I close this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ayang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1210045

Comment 4

3 years ago
Hi Alfredo,

I tried with the latest Aries and Flame build, but found that if connect network back have ever gone into settings-> Wi-Fi page, after tap "<" button to go back browser window would easily meet crash issue.
Please refer: https://youtu.be/H9j2K2MFYck

Test Build:
[Flame]
Build ID               20151022003617
Gaia Revision          1b902ff26547e2a6c896351a6a73b673f65e19b2
Gaia Date              2015-10-21 14:56:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/daa7d98525e859d32a3b3e97101e129a897192a1
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151021.235526
Firmware Date          Wed Oct 21 23:55:35 UTC 2015
Bootloader             L1TC000118D0

[Aries]
Build ID               20151022003511
Gaia Revision          1b902ff26547e2a6c896351a6a73b673f65e19b2
Gaia Date              2015-10-21 14:56:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/daa7d98525e859d32a3b3e97101e129a897192a1
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151021.235445
Firmware Date          Wed Oct 21 23:54:53 UTC 2015
Bootloader             s1
Status: RESOLVED → REOPENED
Flags: needinfo?(ayang)
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

3 years ago
(In reply to Alison Shiue from comment #4)
> Hi Alfredo,
> 
> I tried with the latest Aries and Flame build, but found that if connect
> network back have ever gone into settings-> Wi-Fi page, after tap "<" button
> to go back browser window would easily meet crash issue.
> Please refer: https://youtu.be/H9j2K2MFYck

I can reproduce it and digging it now. Thanks for the reference video.
Flags: needinfo?(ayang)
(Reporter)

Comment 6

3 years ago
Assign to Alfredo to further check. 
Alfredo, thanks!
Assignee: nobody → ayang
(Reporter)

Comment 7

3 years ago
This bug seems related to bug 1207198. The crash in Bug 1189143 comment 18 occurs @AsyncReadMetadata as bug 1207198.
(Assignee)

Comment 8

3 years ago
Hi,
Could you please try latest build if this bug exists?
I can't reproduce it after bug 1174721.
Thank you.
Flags: needinfo?(ashiue)

Comment 9

3 years ago
Good! I cannot reproduce this issue with the latest build.

Build info:
[Flame]
Build ID               20151025150204
Gaia Revision          1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gaia Date              2015-10-23 17:01:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d53a52b39a95dced722cca90ac74529b66dd5253
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151025.201952
Firmware Date          Sun Oct 25 20:20:05 EDT 2015
Bootloader             L1TC000118D0

[Aries]
Build ID               20151025085903
Gaia Revision          1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gaia Date              2015-10-23 17:01:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d53a52b39a95dced722cca90ac74529b66dd5253
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151025.081846
Firmware Date          Sun Oct 25 08:18:54 UTC 2015
Bootloader             s1
Flags: needinfo?(ashiue)
(Assignee)

Comment 10

3 years ago
Thank you.
Let's keep this bug for a while to ensure it is solved.

Comment 11

3 years ago
According to Comment 9, close this bug.

Please reopen this bug, if we hit it again.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.