IndexedDB actorsParent crash on Z3c after x-heavy reference workload

RESOLVED WORKSFORME

Status

()

Core
DOM: IndexedDB
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: gerard, Assigned: janv)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8673615 [details]
gdb stacktrace

STR:
 0. Build & flash Z3c L opt
 1. make reference-workload-x-heavy

Expected:
 Boots properly

Actual:
 Segfault
(Reporter)

Comment 1

2 years ago
Created attachment 8673616 [details]
gdb session content
(Reporter)

Comment 2

2 years ago
As far as I can say, it is 100% repro when starting from a clean state.
blocking-b2g: --- → 2.5+
See Also: → bug 1214222
(Reporter)

Comment 3

2 years ago
We might be exactly hitting what Kyle said on bug 1203803 comment 123
I don't think this is related to bug 1203803.

Comment 5

2 years ago
It is for L. Should it be a blocker?
blocking-b2g: 2.5+ → 2.5?
(Reporter)

Comment 6

2 years ago
(In reply to Ken Chang[:ken] from comment #5)
> It is for L. Should it be a blocker?

I had the issue on L because I was working on something else, but I doubt it's because of L specifically ...
I reproduced on kk as well.
Summary: IndexedDB actorsParent crash on Z3c L after x-heavy reference workload → IndexedDB actorsParent crash on Z3c after x-heavy reference workload
The error code nsresult here is NS_ERROR_DOM_INDEXEDDB_ABORT_ERR.
Jan, can you look into this?  If the workload reflects real life usage, it seems like we should block B2G 2.5 on it.  Jan, that means we have ~1.5 weeks :/
Assignee: nobody → Jan.Varga
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(Jan.Varga)
Jan is now set up with a b2g environment and is working on this.
Flags: needinfo?(Jan.Varga)
Jan, Can you please post any progress on this bug? Thanks
Flags: needinfo?(Jan.Varga)
(Assignee)

Comment 12

2 years ago
I can't reproduce it anymore. Bug 961049 or something else might have fixed it.
Can someone verify it ? Thanks.
Flags: needinfo?(Jan.Varga)
Adding NI to Alexendre/Gregor to try reproducing it.
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(anygregor)
(Reporter)

Comment 14

2 years ago
Looks like I don't reproduce anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(anygregor)
Resolution: --- → WORKSFORME
(Assignee)

Comment 15

2 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #14)
> Looks like I don't reproduce anymore.

Wow, thanks for verifying!
If bug 961049 fixed this (a 2.5+ bug), do we need to uplift bug 961049 to 2.5? It's a big change ...
Flags: needinfo?(mpotharaju)
(Reporter)

Comment 17

2 years ago
(In reply to Andrew Overholt [:overholt] from comment #16)
> If bug 961049 fixed this (a 2.5+ bug), do we need to uplift bug 961049 to
> 2.5? It's a big change ...

So I took gecko at the commit just before bug 961049 landed, and I don't repro the issue either.
(Assignee)

Comment 18

2 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #17)
> (In reply to Andrew Overholt [:overholt] from comment #16)
> > If bug 961049 fixed this (a 2.5+ bug), do we need to uplift bug 961049 to
> > 2.5? It's a big change ...
> 
> So I took gecko at the commit just before bug 961049 landed, and I don't
> repro the issue either.

Ok, so something else must have changed. Hm...
Based on comment 17, we will not uplift bug 961049 to 2.5
Flags: needinfo?(mpotharaju)
You need to log in before you can comment on or make changes to this bug.