[xpmenu] crash on exit processing straggling key event

VERIFIED FIXED in M12

Status

()

Core
XUL
P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Chris Waterson, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
To reproduce:

1. Start apprunner.
2. "Alt+F" to open file menu.
3. Use arrow keys to navigate to "Quit" menu
4. Hit "Enter" to activate choice

This causes a crash, because the XUL document will have been destroyed by the
time the event comes through XULDocumentImpl::HandleDOMEvent(). This may be a
dup of 11299; however, I believe that in this case we need to make sure that
the XUL doc unregisters as a key event listener. Maybe. Who knows.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

19 years ago
Blocks: 12673

Updated

19 years ago
Blocks: 12670
(Assignee)

Comment 1

19 years ago
My hands have deteriorated to the point where I can no longer type.  I need
help.  If you think you can fix this bug on your own, please take it away from
me.  If you'd like to volunteer to be my hands for a specific bug, then I'll be
happy to come up to your cube and sit with you and fix the bug (assuming you
have the patience for that).

Comment 2

19 years ago
Trying to give hyatt a hand: this doesn't crash on linux, with any menu item
(i.e. it works on Quit, it works on anything I try)
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 3

19 years ago
Marking REOPENED.
Reason:  This crash still happens on NT 102709 apprunner on the first time only.
All subsequent attempts at reproduction of bug work juuuuuuuuust fine.

Also, works fine on Linux6 102708 apprunner.  MacOS does not have this
feature/ability (accelerator keys).

Updated

19 years ago
Resolution: FIXED → ---

Comment 4

19 years ago
Clearing FIXED resolution due to reopen of this bug.

Updated

19 years ago
Target Milestone: M11 → M12

Comment 5

19 years ago
[alt+f] doesn't seem to be working here at the end of m11 on win95,
but we are not crashing on quit from the menu selection.

moving off to m12, but I think we should close this and open
a new bug for keyboard nav not working.  that one most likely
won't be hyatt's bug
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Comment 7

18 years ago
Marking VERIFIED FIXED on:
- Linux6 2000-03-01-13 Commercial build
- MacOS9 2000-03-01-13 Commercial build
- Win98 2000-03-01-16 Commercial build
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: ckritzer → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.