Crash opening new browser window

RESOLVED DUPLICATE of bug 114292

Status

()

Core
Networking: Cache
--
critical
RESOLVED DUPLICATE of bug 114292
17 years ago
17 years ago

People

(Reporter: brian, Assigned: gordon)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla often (not always) crashes when i open a new browser window. There is no
obvious way to make this always reproducible. There are a number of talkbacks
from these crashes, the most recent at approx 4:05pm E.S.T. 23/1/2002, all have
my email address: briancort@yahoo.com. Doubt it matters, but my homepage (i.e.
the page being opened) is https://mail.yahoo.com/, just in case it has anything
to do with the https stuff.

I realize that there are a number of existing bugs relating to various other
platforms, plug-ins, etc., but i didn't see any for win2000 or not based on a
specific plugin.

Comment 1

17 years ago
Please include your build id in bug reports. Also, this is "critical", but not a
"blocker". And, try runnin <mozdir>\components\talkback\talkback.exe or whatever
it's called in the winworld, to try to find the talkback ids.
Thank you. (:
(Reporter)

Comment 2

17 years ago
build-id: 2001122106

sorry, set 'blocker' severity becauase the other similar bugs all seemed to have it.

Here are the incident id's for this problem:

TB2026588E
TB1973009H
TB1826622G
TB1739821Q
TB1498186M
TB1495215M
Severity: blocker → critical
(Reporter)

Comment 3

17 years ago
TB2114965K
TB2077879G
(Reporter)

Comment 4

17 years ago
Also crashed using ALT-Home on an existing window: TB2262212E. So maybe its
something to do with opening the page, rather than opening the new window?
Perhaps due to the page being opened a secure page?

Mozilla is crashing about twice a day now for me.
(Reporter)

Comment 5

17 years ago
More crashes from using ALT-Home to go to https://mail.yahoo.com/:

TB2489782Z
TB1973009H

So, I'm more and more suspecting there is a problem loading the secure homepage,
and not a new browser window issue.

Updated

17 years ago
Keywords: crash, stackwanted
Please try with a *trunk* build, thanks.

Stack Signature  0x04084c32 55b77b0e
Trigger Time 2002-01-22 09:15:45
Email Address briancort@yahoo.com
URL visited https://mail.yahoo.com
User Comments alt-home to go to homepage in same window. something with the https???
Build ID 2001122109
Product ID MozillaBranch
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
0x04084c32
nsCacheEntryHashTable::GetEntry
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheEntry.cpp, line 505]
nsMemoryCacheDevice::DeactivateEntry
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsMemoryCacheDevice.cpp, line 161]
nsCacheService::DeactivateEntry
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheService.cpp, line 1290]
nsCacheService::CloseDescriptor
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheService.cpp, line 1244]
nsCacheEntryDescriptor::Close
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheEntryDescriptor.cpp, line 340]
nsCacheEntryDescriptor::~nsCacheEntryDescriptor
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheEntryDescriptor.cpp, line 49]
nsCacheEntryDescriptor::`scalar deleting destructor'
nsCacheEntryDescriptor::Release
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheEntryDescriptor.cpp, line 32]
nsCOMPtr_base::assign_with_AddRef
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 74]
nsHttpChannel::ProcessResponse
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 514]
nsHttpChannel::OnStartRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 2340]
nsOnStartRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 162]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 303]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1280]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1597]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1615]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
Keywords: stackwanted
(Reporter)

Comment 7

17 years ago
i don't think i'll be able to try this with a trunk build. at least i don't know
how. i checked out the nightly ftp directory, but it only seems to have files
labelled for linux and i'm using win2000. i could easily be missing something,
and with detailed instructions would be happy to run a reaonabl stable nightly
for a while to help diagnose this problem. please let me know.

thanks,
brian.

Comment 8

17 years ago
try 
http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/mozilla-win32-talkback.
zip
Assignee: asa → gordon
Component: Browser-General → Networking: Cache
QA Contact: doronr → tever

Comment 9

17 years ago
WFM Win2K SP2 buildid 2002020406
setting my home page to https://mail.yahoo.com, opening a new window, or using
alt-home on an existing one gives no problems.
(Reporter)

Comment 10

17 years ago
I still need to install and try a trunk build. It only crashes occassionally for
me. Most of the time it works for me too. Please give me a few days to get to
this. Thanks.
(Assignee)

Comment 11

17 years ago
This is a duplicate of bug 114292 which was fixed on 01/18/2002.  Brian, please
go ahead and try reproducing with a current build.  If you crash on opening a
new browser window and the stack trace looks the same, you can reopen this bug.
 Otherwise, create a new bug.

Thanks.

*** This bug has been marked as a duplicate of 114292 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.