Mail containing Part 1.1 attachments bugs

RESOLVED DUPLICATE of bug 101719

Status

MailNews Core
MIME
RESOLVED DUPLICATE of bug 101719
16 years ago
9 years ago

People

(Reporter: Chea Chee Keong, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET 
CLR 1.0.3705)
BuildID:    2002011604

Mails containing nested mime multiparts may exhibit Part 1.1++ attachments 
which should not be shown to the user.

Example mail file is shown below

From NOBODY Thu Jan 24 11:19:18 2002
X-UIDL: 3c4bd2e000000005
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-Path: <nobody@nowhere.com>
From: "Nobody" <nobody@noboddy.com>
To: "Someone" <nobody@nobody.com>
Subject: Test Mail
Date: Thu, 24 Jan 2002 11:16:24 +0000
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="----=ABC"

------=ABC
Content-Type: multipart/mixed;
	boundary="----=GHI"

------=GHI
Content-Type: multipart/alternative;
	boundary="----=JKL"

------=JKL
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit

For your review.

------=JKL
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1">
<META content="MSHTML 6.00.2712.300" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT face=Arial size=2>For your review.</FONT></DIV></BODY>
</HTML>

------=JKL--

------=GHI--

------=ABC
Content-Type: text/plain; name=Testing.txt
Content-Disposition: inline; filename=Testing.txt

Testing.txt
------=ABC--

Reproducible: Always
Steps to Reproduce:
Use the mail attached in the description

Actual Results:  Part 1.1 in the attachment box

Expected Results:  Part 1.1 should not be there

Comment 1

15 years ago
Is this still a problem, if so, please explain: What is it that should be
displayed and what is actually displayed.

pi

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 101719 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.