Closed Bug 1215535 Opened 6 years ago Closed 6 years ago

Deprecation warning in viewSource.xul

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.38 Branch
defect
Not set
minor

Tracking

(seamonkey2.41 unaffected, seamonkey2.42 unaffected, seamonkey2.43 affected, seamonkey2.44 unaffected, seamonkey2.46 unaffected)

RESOLVED WORKSFORME
seamonkey2.39
Tracking Status
seamonkey2.41 --- unaffected
seamonkey2.42 --- unaffected
seamonkey2.43 --- affected
seamonkey2.44 --- unaffected
seamonkey2.46 --- unaffected

People

(Reporter: raj, Unassigned, Mentored)

Details

(Whiteboard: [good first bug][gfb][lang=js])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0 SeaMonkey/2.38
Build ID: 20150923195647

Steps to reproduce:

Open any web (eg www.google.com) and press ctrl+U (to view source).


Actual results:

The source window opens as expected, but the following error is logged to the Error Console:

Timestamp: 16/10/2015 15:40:20
Error: DEPRECATION WARNING: The arguments you're passing to viewSource.xul are using an out-of-date API.
You may find more details about this deprecation at: https://developer.mozilla.org/en-US/Add-ons/Code_snippets/View_Source_for_XUL_Applications
chrome://global/content/viewSource.js 316 _loadViewSourceDeprecated
chrome://global/content/viewSource.js 302 onXULLoaded
chrome://global/content/viewSource.js 175 handleEvent
null 0 null

Source File: resource://gre/modules/Deprecated.jsm
Line: 79


Expected results:

No deprecation warning should be logged to the Error Console.
Severity: normal → minor
Mentor: philip.chee, neil
Whiteboard: [good first bug][gfb][lang=js]
Hi, I'm new to open source and the Mozilla community and figured this would be a good task to start on. Can this be assigned to me?
If no one else is working on this, I would like to take it up. Any help regarding where the files are located in the source would be great.
Hi, is this bug still aktive?
I tried a couple of pages and was not able to reproduce the error.
a) No longer reproducible with  
a1) English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)
  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)
  on German WIN7 64bit
a2) SeaMonkey German 2.39 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0
  from official download area)  Gecko/20100101  Firefox/42.0  
  Build 20151103191810  (Default  Classic Theme) on German WIN7 64bit

b) REPRODUCIBLE with  
* en-US (German language pack) SeaMonkey 2.38  (Windows NT 6.1; WOW64; rv:41.0)
  Gecko/20100101 Firefox/41.0 Build 20150923195647  (Default  Classic Theme) 
  on German WIN7 64bit

So WFM! I did not do own tests for 2.41 ... 2.44
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → seamonkey2.39
You need to log in before you can comment on or make changes to this bug.