SVG feBlend with in2 from a feImage result linking to an embedded SVG document rendered wrong

RESOLVED DUPLICATE of bug 455986

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 455986
3 years ago
3 years ago

People

(Reporter: Andres Gomez, Unassigned)

Tracking

37 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8674949 [details]
win8.1_firefox_37.0.png

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/602.1 (KHTML, like Gecko) Version/8.0 Safari/602.1 Epiphany/3.18.0

Steps to reproduce:

Open the URL:
https://rawgit.com/tanty/design-hodgepodge/master/svg/filter/feBlend-feImage-tests.html

All the SVGs include a filter using a feImage to feed a feBlend element used by another elements in the SVG file.

The feImage links to another embedded SVG document included in the "defs" element of the main document.


Actual results:

All the SVGs are shown as the included PNG as reference



Expected results:

All the SVGs fail to be rendered correctly, only displaying the embedded SVG document included in the "defs" element of the main document.
(Reporter)

Comment 1

3 years ago
(In reply to Andres Gomez from comment #0)
...
> Actual results:
> 
> All the SVGs are shown as the included PNG as reference
> 
> 
> 
> Expected results:
> 
> All the SVGs fail to be rendered correctly, only displaying the embedded SVG
> document included in the "defs" element of the main document.

This is the other way around.

Actual results:

All the SVGs fail to be rendered correctly, only displaying the embedded SVG document included in the "defs" element of the main document.


Expected results:

All the SVGs are shown as the included PNG as reference
(Reporter)

Updated

3 years ago
See Also: → bug 437554
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455986
You need to log in before you can comment on or make changes to this bug.