Cannot launch vidyo from Firefox, it shows toast saying "Couldn't find an app to open this link"

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: noitidart, Assigned: mcomella)

Tracking

(Blocks: 1 bug)

unspecified
Points:
---

Firefox Tracking Flags

(fennec+)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151012151721

Steps to reproduce:

I installed vidyo mobile.

I opened the vidyo join link in firefox.
 https://v.mozilla.com/flex.html?roomdirect.html&key=mk8UtsxkzzqV

I click the "Join" icon and it shows a toast:

"Cannot launch vidyo from Firefox, it shows toast saying "Couldn't find an app to open this link"

I tried from the default browser and it popped open in mobile vidyo just fine. I went back to firefox to test and it still wouldn't work.
Blocks: 1182695
Component: Untriaged → General
Product: Firefox → Firefox for Android
Version: 42 Branch → unspecified
I have still not confirmed this bug.

This doesn't work for Vidyo but could be indicative of larger Intent handling problems.
tracking-fennec: --- → ?
Assignee: nobody → michael.l.comella
Mike - Can you dig a little deeper here? What mimetype or URL is the 'Join' action doing?

Updated

3 years ago
tracking-fennec: ? → +
Kevin, I can't reproduce this – can you?

It's possible we made intent handling changes since this bug was filed.
Flags: needinfo?(kbrosnan)
Also, can you still reproduce this, noitidart? If so, which version of Firefox are you using?
Flags: needinfo?(noitidart)
Room in comment 0 seems to be not valid. 

https://v.mozilla.com/flex.html?roomdirect.html&key=M4APpM9S3fr9
Flags: needinfo?(kbrosnan)
Using the room in comment 5 works for me.
(In reply to Kevin Brosnan [:kbrosnan] from comment #6)
> Using the room in comment 5 works for me.

Clarified on IRC – he was able to go to the room without the error in comment 0.
(Reporter)

Comment 8

2 years ago
Hi Mchael,
That tablet I used is totally battery dead right now Ill charge it up and get back to you as soon as it turns on.
> > Using the room in comment 5 works for me.
> 
> Clarified on IRC – he was able to go to the room without the error in
> comment 0.

No the link to the vidyo room in comment 0 no longer exists. One should test with a vidyo room that is valid such as the one in comment 5.
(Reporter)

Comment 10

2 years ago
Hey guys, my tablet is not working, it's an ancient one I got for testing. If it's working for @kbrosnan than it probably is working now for me too. :) Apologies, I wish I could test this. If I do get this working though I'll be sure to post :)
Sure – let us know! Thanks for responding.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

2 years ago
Hey Mike, just got my android working, its working now. Yahoo!
Flags: needinfo?(noitidart)
(In reply to noitidart from comment #12)
> Hey Mike, just got my android working, its working now. Yahoo!

Great! Thanks for reporting back!
You need to log in before you can comment on or make changes to this bug.