newtab tile's page thumbnail is not scaled correctly (HiDPI problem?)

RESOLVED FIXED in Firefox 44, Firefox OS v2.5

Status

()

Firefox
New Tab Page
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: mchang)

Tracking

unspecified
Firefox 45
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox44 fixed, firefox45 fixed, b2g-v2.5 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8675097 [details]
newtab-screenshot.png

I am using Nightly 44 with e10s on a Retina MacBook Pro. I have seen similar content scaling bugs when dragging e10s browser windows between my MacBook Pro's builtin Retina display and an external non-HiDPI display, e.g. bug 1125325 and bug 978913.

See the attached screenshot.

Comment 1

3 years ago
Might be a regression from bug 1197361.
Flags: needinfo?(mchang)
(Assignee)

Comment 2

3 years ago
Yup, probably a regression from 1197361.
Assignee: nobody → mchang
Flags: needinfo?(mchang)
(Assignee)

Updated

3 years ago
See Also: → bug 1214428
(Assignee)

Comment 3

3 years ago
Created attachment 8677208 [details] [diff] [review]
Use destination canvas as thumbnail size

There was a problem, where sometimes we would be provided with a destination canvas already, but we'd go down a path to try to take the snapshot at a size smaller than the destination canvas. In those cases, just try to snapshot at the destination canvas size.

Also, sometimes, we'd get a black canvas because nsIProgressWatcher would actually give us an error, but we'd continue to snapshot the page. The web content wasn't actually ready, so we'd snapshot nothing.
Attachment #8677208 - Flags: review?(ttaubert)

Updated

3 years ago
tracking-e10s: ? → +
Attachment #8677208 - Flags: review?(ttaubert) → review?(adw)

Comment 4

3 years ago
Comment on attachment 8677208 [details] [diff] [review]
Use destination canvas as thumbnail size

Review of attachment 8677208 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for fixing that second problem too, that's great.
Attachment #8677208 - Flags: review?(adw) → review+

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f6b31718d94d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
(Assignee)

Comment 7

3 years ago
Comment on attachment 8677208 [details] [diff] [review]
Use destination canvas as thumbnail size

Approval Request Comment
[Feature/regressing bug #]: Regression from bug 1197361.
[User impact if declined]: Can get black screenshots shown during newtab images.
[Describe test coverage new/current, TreeHerder]: Mochitests in tree herder, manual tests.
[Risks and why]: Low, this change makes sure we correctly size the thumbnails.
[String/UUID change made/needed]: None
Attachment #8677208 - Flags: approval-mozilla-aurora?

Comment 8

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/f6b31718d94d
status-b2g-v2.5: --- → fixed

Updated

3 years ago
status-b2g-v2.5: fixed → ---
status-firefox44: --- → affected

Comment 9

3 years ago
Comment on attachment 8677208 [details] [diff] [review]
Use destination canvas as thumbnail size

Given that this was manually tested, has automated mochitest coverage and has been in Nightly for a few days, let's uplift to Aurora44.
Attachment #8677208 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 10

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/7b8547621a2e
status-firefox44: affected → fixed

Updated

3 years ago
Depends on: 1231518

Updated

2 years ago
Depends on: 1247641
You need to log in before you can comment on or make changes to this bug.