[e10s] When the content process stops/starts its volume is reset.

RESOLVED DUPLICATE of bug 1041599

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1041599
3 years ago
3 years ago

People

(Reporter: johan.charlez, Unassigned)

Tracking

({qawanted})

43 Branch
qawanted
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

3 years ago
STR:
0. Enable e10s.
1. Set Windows' master volume to e.g. 50% (or something that doesn't kill your ears).
2. Set the Nightly process _and_ Nightly's content process to 25%.
3. Restart Nightly.

Expected result:
* Both processes should remain at 25% volume.

Actual result:
* The Nightly process remains at 25%, its content process however has been reset(?) to whatever Windows' master volume is set at (50% in this case).

Note: I'm filing this under widget:win32 for now, feel free to correct this if you can confirm this bug on other platforms.
Keywords: productwanted
(Reporter)

Comment 1

3 years ago
The content process doesn't actually reset when Firefox starts/closes. It either resets when the content process stops or when it starts.

Updated STR:
0. Enable e10s.
1. Open two tabs.
  1.1. Tab_1 with a chrome-url (e.g. about:newtab, we need the content-process to shut down when we close Tab_2).

  1.2. Tab_2 with something on youtube (e.g https://www.youtube.com/watch?v=cUYSGojUuAU).
2. Set the volume of the content process to anything below Windows' master volume.
3. Close Tab_2.
  3.1. Wait for content process (Plugin Container for Nightly) to shut down.
4. Reopen Tab_2.

Actual:
* When the content process starts (after STR step 4), its volume resets to Windows' master volume.

Expected:
* The volume should not reset. (╯°□°)╯︵ ┻━┻
(Reporter)

Updated

3 years ago
Summary: [e10s] The content process' volume resets on startup. → [e10s] When the content process stops/starts its volume is reset.

Updated

3 years ago
Component: Widget: Win32 → DOM: Content Processes
tracking-e10s: --- → +
Product Triage: Not a blocker for e10s going to GA. Resolve after if possible.
Keywords: productwanted
Hi,

I've managed to reproduce this on the latest Aurora build (46.0a2) and the latest Nightly (47.0a1). In both cases the plugin container resets to the Windows master volume default.

Build ID 	20160204004009
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0

Thanks,
Cipri

Updated

3 years ago
Keywords: qawanted
Priority: -- → P2
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041599
You need to log in before you can comment on or make changes to this bug.